Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20417 - [truecrypt] 7 '--filesystem=ntfs-3g' Option Not Working

Attached to Project: Arch Linux
Opened by Natanji (Natanji) - Monday, 09 August 2010, 10:11 GMT
Last edited by Paul Mattal (paul) - Monday, 27 September 2010, 02:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Paul Mattal (paul)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
Since upgrading Truecrypt 6.3a-1 -> 7.0-1, the following command:
truecrypt --filesystem=ntfs-3g /dev/sda1 /mnt/tc
produces this error message:
Unknown option: ntfs-3g
The command has worked fine until now and is required to mount NTFS volumes (wuthout it, truecrypt tries to mount the volume as FAT32). I guess most Truecrypt volumes are NTFS, so this is a very serious problem.

Additional info:
* package version(s): 7.0-1

Steps to reproduce:
Try mounting a NTFS volume with --filesystem=ntfs or --filesystem=ntfs-3g.
This task depends upon

Closed by  Paul Mattal (paul)
Monday, 27 September 2010, 02:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  This is resolved in truecrypt 7.0a, now in [extra].
Comment by Peter Kerwien (pkerwien) - Tuesday, 10 August 2010, 22:50 GMT
I'm able to mount my encrypted NTFS volume (Created under Win 7) with:

truecrypt /.../volume.tc /media/truecrypt1

I.e. excluding the filesystem type. Does it work for you?
Comment by Paul Mattal (paul) - Wednesday, 11 August 2010, 11:13 GMT
I have replicated the issue. Haven't yet figured out what it is, but am working on it.

A workaround seems to be to mount the truecrypt container without mounting the filesystem, then mount the /dev/mapper/truecryptX device manually using mount -t ntfs-3g /dev/mapper/truecryptX /mnt/<wherever>.
Comment by Bernhard Friedreich (friesoft) - Saturday, 11 September 2010, 12:10 GMT
I can also confirm this issue... very annoying :(
Comment by Natanji (Natanji) - Sunday, 26 September 2010, 10:27 GMT
Any news yet? This is keeping me from upgrading truecrypt for months already, which doesn't exactly seem too clever with heavily security-relevant software.
Comment by Jakob Gruber (schuay) - Sunday, 26 September 2010, 11:22 GMT
Sorry to repeat what pkerwien already suggested, but have you tried mounting without the --filesystem option? Works fine here, automatically uses ntfs-3g.
Comment by Natanji (Natanji) - Sunday, 26 September 2010, 14:47 GMT
I somehow must have overlooked that. Yes, that does work - so maybe they just introduced some autodetection in the new version then I guess? Thanks anyways!

Loading...