Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20405 - [lynx] Please include offline help in package

Attached to Project: Arch Linux
Opened by Mario Figueiredo (marfig) - Sunday, 08 August 2010, 03:45 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 08 September 2010, 14:36 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Dan Griffiths (Ghost1227)
Giovanni Scafora (giovanni)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
1. Lynx help system is defined by lynx.cfg in setting HELPFILE.
2. Currently, lynx.cfg defaults to online URI.
3. But upstream removes older versions help system from the web when a new stable version is made available. When this happens, lynx help system is rendered inoperative, resulting in a HTTP 404 error message until a new package is released in Extra, or user takes action.
4. Upstream sources include the help system for offline access in lynx_help folder.
5. Upstream suggests users should link to offline help (see HELPFILE comment in lynx.cfg)

Please, implement offline help.


Additional info:
* 2.8.7-2
* lynx.cfg (HELPFILE)
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 08 September 2010, 14:36 GMT
Reason for closing:  Implemented
Additional comments about closing:  lynx 2.8.7-3
Comment by Pete (tam1138) - Tuesday, 17 August 2010, 05:10 GMT
This is a duplicate of  bug 20404 .
Comment by Mario Figueiredo (marfig) - Tuesday, 17 August 2010, 15:54 GMT
No. Bug #2404 refers to a wrong default setting in the configuration file for this version of Lynx. This feature request (#2040), on the other hand, kindly requests that the package starts including the offline help system as upstream intended. It doesn't request the packager should change the configuration file to link to this offline help. That task can be delegated to the user.

Loading...