Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20373 - [kernel26] i915: Invisible mouse cursor with kernel .35

Attached to Project: Arch Linux
Opened by Janusz Lewandowski (LEW21) - Wednesday, 04 August 2010, 18:58 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 27 September 2010, 13:35 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Thomas Bächler (brain0)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 20
Private No

Details

After updating kernel to 2.6.35 from Arch's testing repository, my mouse cursor disappeared. I was able to use it normally (move, hover, click, etc), but it wasn't displayed. I've had to revert to core's kernel 2.6.34.

I'm using Intel i915 KMS driver on Intel 82852/855GM Integrated Graphics Device.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 27 September 2010, 13:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.6.35.6-1
Comment by Pierre Schmitz (Pierre) - Wednesday, 04 August 2010, 19:36 GMT
I can confirm this issue. It works when using the fbdev xorg driver though.
Comment by Thomas Bächler (brain0) - Wednesday, 04 August 2010, 20:13 GMT
Do the hwcursor/swcursor xorg config options still exist? If yes, you could try disabling the hardware cursor.
Comment by Ronald van Haren (pressh) - Thursday, 05 August 2010, 09:05 GMT
don't think the option exists anymore, I have 'Option "HWCursor" is not used when trying to disable it. Same for swcursor trying to enable it.

the kernel26-rc 2.6.35 rc6 package from AUR I installed last week does work though
Comment by Alexander Dunlap (ajd) - Tuesday, 10 August 2010, 01:15 GMT
This problem affects me too.
Comment by Thomas Dziedzic (tomd123) - Tuesday, 10 August 2010, 15:49 GMT
I'm using i915 with 945gm and kernel26-rc (2.6.35) and xf86-video-intel-git and I don't have this issue.
Comment by frederick_metzengerstein (metzengerstein) - Thursday, 19 August 2010, 14:40 GMT
Same problem (with same graphics device) with the kernel26 2.6.35.2-1 from core.
Comment by Pierre Schmitz (Pierre) - Thursday, 19 August 2010, 14:45 GMT
A workaround is to uninstall xf86-video-intel and use xf86-video-fbdev instead.
Comment by Alexander Dunlap (ajd) - Thursday, 19 August 2010, 17:18 GMT
That workaround works for me too. But it prevents returning to the console after killing Xorg, necessitating a hard reboot of the computer (blank screen).
Comment by Stefan Mark (0mark) - Friday, 20 August 2010, 05:56 GMT
I have the same problem, seems to be this:

https://bugs.freedesktop.org/show_bug.cgi?id=29413

As stated there, suspending and resuming brings back my mouse cursor.
Comment by Austin (doorknob60) - Friday, 20 August 2010, 20:01 GMT
I can confirm this on a laptop with 855GM, happend when I updated 2 days ago (likely the .35 kernel, in [core] now). xf86-video-fbdev fixes it, but I'd rather use the intel driver, I'm sure that driver works better with 3D accelleration :) I'll use the fbdev driver until this gets fixed (it works well enough for sure), but I'd really like it to get fixed soon.
Comment by Christian Neukirchen (chneukirchen) - Monday, 23 August 2010, 15:56 GMT
Confirmed with a 82852/855GM on a Thinkpad X40.
Comment by Vladimir (vlstefanovic) - Tuesday, 24 August 2010, 09:45 GMT
Same problem here.
Comment by Pierre Schmitz (Pierre) - Tuesday, 24 August 2010, 09:52 GMT
It is already confirmed that this bug affects the 8xx chipset. So there is no point to add more "same here" comments.
Comment by Stefan Mark (0mark) - Tuesday, 24 August 2010, 09:57 GMT
I switched back to 2.6.34.3-1 until this is solved. Here is the package if needed:
http://0mark.unserver.de/filez/kernel26-2.6.34.3-1-i686.pkg.tar.xz
Comment by Taboom (taboom) - Tuesday, 24 August 2010, 18:33 GMT
For me the xf86-video-fbdev driver does not work. It messes up the resolution and/or the refresh rate and scrambles the screen. Wierdly this also affects the consoles if X has been started. My solution was to downgrade to .34 until this gets solved.
Comment by Korab (Korab) - Thursday, 26 August 2010, 07:49 GMT
I have the same problem (kernel26 2.6.35.2-1 from core)
Comment by awhan patnaik (awhan) - Friday, 27 August 2010, 02:15 GMT
I faced the same problem on my Thinkpad R51

$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

reverting back to 2.6.34 solved it for me
Comment by jr0501 (jr0501) - Saturday, 28 August 2010, 14:43 GMT
the problem of mouse cursor still lies in the new kernel26 2.6.35.4-323.1
Comment by Michael (myk) - Wednesday, 01 September 2010, 19:48 GMT
But problem may be in X, because all X packages compiled under kernel 2.6.34.
I'll try to rebuild X under .35 and vary hope that it may solve this problem.
Comment by jr0501 (jr0501) - Thursday, 02 September 2010, 01:32 GMT
Michael:the problem of mouse disappears?
Comment by Artur Chmarzyński (PanArtur83) - Thursday, 02 September 2010, 18:17 GMT
I have compiled (ABS) following packages: xf86-video-vesa xorg-docs xorg-fonts-100dpi xorg-fonts-75dpi xorg-res-utils xorg-serxorg-server-utils xorg-twm xorg-utils xorg-xinit xf86-video-intel
But cursor is still missing.
Comment by jr0501 (jr0501) - Friday, 03 September 2010, 14:41 GMT
thanks.the problem may be in kernel.
Comment by Michael (myk) - Saturday, 04 September 2010, 20:48 GMT
X compilation can't solve problem. I found this "magic" sequence (return cursor for one session): booting without X, startx, press any keys on tty with startx (it typically hangs X session), press Ctrl+C to cancel X, reboot and see cursor. IMHO it means that problem not in kernel or not only in kernel, but I have an idea to trace changes in all system files and find difference between 2 boots.
Comment by Austin (doorknob60) - Monday, 06 September 2010, 23:32 GMT
For me, the easiest solution I've found (besides the fbdev driver, which makes 3D acceleration not work well) is to install the kernel26-lts package (and use it instead of kernel26). Works perfect for me (as far as I've tested at least).
Comment by psyX (psyX) - Tuesday, 07 September 2010, 10:53 GMT
Another sequence: goto sleep and get back.
Comment by Petr Jezek (pjezek) - Wednesday, 15 September 2010, 13:05 GMT
Mouse (trackpoint) cursor hase again became visible after downgrading kernel26 from 35 to recent 34 version (note madwifi conflicts with kernel 34!). There must be some linking problem in the last kernel when it communicates with xf86-video-intel module. I see changed or erased identification of cursor icon in X and GUI config files (DM, WM etc.). I remember the cursor temporarily appeared in XFCE4 (kernel 35) when I checked styles and cursor icon settins throughout my and system configs. After relogging in the cursor was lost. Please check all links and auto config changes affected cursor icons when mouse motion is well recognized but not pointing GUI symbol...
Comment by Matthias Hecker (apoc) - Saturday, 18 September 2010, 04:27 GMT
I've the same problem (82852/855GM), tried the different workarounds:
- suspend to ram -> the mouse reappears but is unusable due to periodically 1 second freezes
- kernel downgrading to 2.6.34.3-1-i686 -> works
- switching to lts kernel (2.6.32-lts) -> works
Comment by Pierre Schmitz (Pierre) - Saturday, 18 September 2010, 08:01 GMT Comment by Christos Nouskas (nous) - Monday, 20 September 2010, 21:00 GMT
@Pierre After applying the patch, I cold rebooted three times and the cursor was there.

That's with kernel26-pf, but the cursor was invisible with both -ARCH and -pf. So, it seems that patch solves it.
Comment by Christoph (cschol) - Tuesday, 21 September 2010, 02:16 GMT
Is an official solution for this in sight?
Comment by Petr Jezek (pjezek) - Tuesday, 21 September 2010, 22:19 GMT
I have to work on affected thinkpad daily so I could not try that patch. If the patch leads to repeating reboots, i cannot find it satisfying, sorry, nothing personal :-)
Comment by Christos Nouskas (nous) - Wednesday, 22 September 2010, 04:47 GMT
I'm sorry if I wasn't clear, I meant I *manually* rebooted 3 times to check if it really works. I had to make sure, because occasionally the cursor actually appeared before and I wanted to confirm the patch's effect wasn't random.
Comment by Christos Nouskas (nous) - Wednesday, 22 September 2010, 08:56 GMT
DELETED - repost from browser refresh.

Loading...