Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20365 - [xf86-video-intel] 2.12.0-1 Metacity composition produces shadows instead of windows

Attached to Project: Arch Linux
Opened by Carlos (tatsuno) - Wednesday, 04 August 2010, 09:33 GMT
Last edited by Allan McRae (Allan) - Saturday, 02 June 2012, 11:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

When I upgrade from xf86-video-intel 2.11.0-2 to 2.12.0-1, if metacity composition is enabled, I get either shadows instead of windows or shadows on top of windows, instead of underneath them.

Additional info:

No xorg.conf used.

$ uname -a
Linux hyrule 2.6.34-ARCH #1 SMP PREEMPT Mon Jul 5 22:12:11 CEST 2010 x86_64 Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz GenuineIntel GNU/Linux

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Steps to reproduce:

Upgrade to 2.12.0-1. Restart and enable metacity composition:

$ gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool true
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 02 June 2012, 11:48 GMT
Reason for closing:  No response
Comment by Carlos (tatsuno) - Wednesday, 04 August 2010, 09:49 GMT
Screenshots to illustrate the problem.
Comment by Carlos (tatsuno) - Wednesday, 04 August 2010, 10:03 GMT
I noticed that in the first screenshot I can see only the shadows because the windows are beneath the maximised window, the same that happens in the second screenshot when the shadow of the calculator window (unfocused) gets above the gconf editor's window (focused).
Comment by Carlos (tatsuno) - Thursday, 19 August 2010, 14:19 GMT
I just realised that this problem only appears when using a DUAL MONITOR setup.

Please, can anybody reproduce it?
Comment by Daniel Ehlers (sargon) - Wednesday, 25 August 2010, 21:38 GMT
Hi,

I can't reproduce exactly the same problem, but I also have a problem with the update from 2.11.0-2 to 2.12.0-1
, which results in the same error message in the xorg log.

> [ 54.905] (EE) intel(0): Failed to set tiling on frontbuffer.

In my case the dual monitor setup results in one large screen instead of two separated ones.
I have a 945GME.
Comment by Daniel Ehlers (sargon) - Thursday, 26 August 2010, 07:48 GMT
Does downgrading help in your case? I had to downgrade a couple of package, before the problem went away and I'm thinking that maybe it is not only a xf86-video-intel
problem.
Comment by Carlos (tatsuno) - Thursday, 26 August 2010, 08:49 GMT
In my case, the problem is fixed just downgrading xf86-video-intel.
Comment by Jan de Groot (JGC) - Thursday, 26 August 2010, 16:48 GMT
My guess is that this only happens on extended desktops that go beyond hardware limitations. Running dualscreen usually extends beyond 2048x2048, which is the hardware limiation for pre-965-class hardware. My laptop with G45M works fine for example. I don't have access to my Q35 box that suffers from this problem also, but could someone try the latest xf86-video-intel git snapshot to see if it's fixed? If not, we'll have to bisect this.
Comment by Carlos (tatsuno) - Friday, 27 August 2010, 08:48 GMT
Yes, my desktop goes beyond 2048x2048.

I tried upgrading to xf86-video-intel-2.12.0-2 from testing, which needed an upgrade to xorg-server-1.9.0-1 as well, and, as a result, the system froze at the login screen.

I can try with the git snapshot if you tell me how to get it.
Comment by Carlos (tatsuno) - Tuesday, 07 September 2010, 16:08 GMT
I can confirm the same issue in Ubuntu 10.10 beta after installing updates from xorg-edgers ppa.
Comment by Carlos (tatsuno) - Friday, 10 September 2010, 15:04 GMT
Ok, I have reproduced the bug in Ubuntu 10.10 beta.

If I just install Ubuntu 10.10 beta and set up dual monitor, I get the problem I reported here:

https://bugs.archlinux.org/task/20186

After upgrading libdrm* packages to those from xorg-edgers, that problem is solved, but I get the problem reported here. Therefore, this bug only has to do with libdrm, which was the package whose upgrade solved the problem in  FS#20186 .

Hope that helps.
Comment by Carlos (tatsuno) - Wednesday, 29 September 2010, 13:29 GMT
Jan, I've just tried upgrading to xorg-server-1.9.0-1 and xf86-video-intel-2.12.0-3, which are no longer in testing. My desktop doesn't freeze now, but the bug is still there.

Shall we bisect?

Thanks.
Comment by Jan de Groot (JGC) - Wednesday, 29 September 2010, 14:26 GMT
mesa 7.9 is about to get released and there's a release candidate for xf86-video-intel 2.13.0, so we might try those before bisecting anything. If there's anything that needs bisection for this bug, it's xf86-video-intel. libdrm has nothing to do with this.
Comment by Carlos (tatsuno) - Wednesday, 29 September 2010, 14:33 GMT
Thanks Jan. I'll come back when I try mesa 7.9 and xf86-video-intel 2.13.0.
Comment by Carlos (tatsuno) - Friday, 26 November 2010, 12:16 GMT
Hi Jan. I have just installed mesa 7.9-1 and xf86-video-intel 2.13.0-4. Same problem :(

> fgrep tiling /var/log/Xorg.0.log
[ 26.499] (EE) intel(0): Failed to set tiling on frontbuffer.

Is there anything I can do to help?

Cheers.
Comment by Carlos (tatsuno) - Wednesday, 02 February 2011, 16:49 GMT
Hi again.

Just tried xf86-video-intel 2.14.0-1. Same thing :(

Jan, I wonder if we should report this to upstream, since this happens in Ubuntu as well.

Cheers.
Comment by Carlos (tatsuno) - Monday, 14 February 2011, 12:58 GMT Comment by Allan McRae (Allan) - Saturday, 28 April 2012, 16:12 GMT
Current status?

Loading...