Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20338 - [kernel26] PAE Kernel

Attached to Project: Arch Linux
Opened by Leo Borealis (Architect) - Monday, 02 August 2010, 03:19 GMT
Last edited by Thomas Bächler (brain0) - Wednesday, 04 August 2010, 07:36 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I have a some kind of binary software for linux 32-bit (no 64 bit version, no sources. Yes I know about lib32, but this is a workaround IMHO.) and PC with 6GB of RAM. And IMHO it can be very useful if an linux kernel compiled with PAE support appears in repository.

Sorry for posting this here (this is not a bug, I know...) and sorry for my english.
This task depends upon

Closed by  Thomas Bächler (brain0)
Wednesday, 04 August 2010, 07:36 GMT
Reason for closing:  Won't implement
Additional comments about closing:  We're not going to maintain another kernel for a very small minority of users.
Comment by Leo Borealis (Architect) - Monday, 02 August 2010, 03:23 GMT
Please don't write here about rebuilding kernel. If I wanted compile kernel every time it's updates, I would use gentoo.
Comment by Karol Błażewicz (karol) - Monday, 02 August 2010, 03:48 GMT
> Sorry for posting this here (this is not a bug, I know...
You could have marked it as a feature request.

Some people would like to have -ck kernel, others want a monolithic one - there's AUR and unofficial repos to suit their needs.
Comment by Jan de Groot (JGC) - Monday, 02 August 2010, 08:09 GMT
You can always use a 64bit kernel with 32bit userspace when the hardware supports 64bit. In fact, using such a kernel is recommended over a highmem or PAE kernel whenever your hardware supports 64bit.
Comment by JM (fijam) - Monday, 02 August 2010, 19:25 GMT
I have a 32bit processor that supports NX bit. To take advantage of it I need PAE. Perhaps it could be considered to add PAE support to kernel26-lts?
Comment by Karol Błażewicz (karol) - Monday, 02 August 2010, 19:31 GMT
Arch tries to be vanilla so I don't think adding PAE support to the lts kernel is a viable option.
Comment by Ionut Biru (wonder) - Monday, 02 August 2010, 19:32 GMT
this feature was requested multiple times and rejected
Comment by JM (fijam) - Monday, 02 August 2010, 22:35 GMT
@Ionut, searching the bugtracker (all statuses) reveals no other requests of that feature. However, it appears that PAE-enabled kernel will not boot on processors that do not support PAE which renders this idea moot.
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 04 August 2010, 03:23 GMT
@JM: if CPU does not have PAE is not an "i686 class processor". Maybe your are refering to PSE36.

Personally I use a custom kernel with PAE enabled in 32 bits (4G, 512M mapped over 4G physical address space). I prefer over 64 bit kernel, to avoid using bounce buffers (an IOMMU) for 32 bit PCI-DMA transfers that in my case is done via AMD GART. What is bad with this? Well if some drivers (sata, ethernet, video, etc) lacks memory reserved for IOMMU: data corruption.

Loading...