Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20324 - [kde] 4.5 RC3 Shutdown won't work

Attached to Project: Arch Linux
Opened by Panos Filip (Flamelab) - Friday, 30 July 2010, 11:23 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 04 August 2010, 16:00 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Ronald van Haren (pressh)
Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Trying to shutdown the system through the Application Launcher > Leave > Shutdown, won't work at all (there isn't even that confirmation window). Shutting down through KDM works though.

No errors shown in ~/.xsession-errors or /var/log/Xorg.0.log, so I guess it's not an Xorg related issue. /var/log/errors or dmesg doesn't report any related problem.

HAL, acpid, dbus, are running succesfully. The system is fully updated (with [testing] enabled).
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 04 August 2010, 16:00 GMT
Reason for closing:  Won't fix
Comment by Ronald van Haren (pressh) - Monday, 02 August 2010, 17:14 GMT
I tried shutting down my i686 laptop which worked.

Are you able to popup the shutting down dialog using the following command:

qdbus org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout 1 2 2
Comment by Ionut Biru (wonder) - Monday, 02 August 2010, 17:51 GMT
are you login into your kde using gdm/kdm or ck-launch-session in .xinitrc?
Comment by Ronald van Haren (pressh) - Monday, 02 August 2010, 17:53 GMT
I supposed he was logged in via kdm as he said logout was working from there, but my assumption may be wrong...
Comment by Panos Filip (Flamelab) - Monday, 02 August 2010, 20:59 GMT
@pressh: That command didn't work at all :S
@wonder: i'm using KDM

The problem is that I can shutdown/reboot properly through KDM, I can do that (of course) through a terminal, but the shutdown dialog won't appear at all, as if there is a problem.
Comment by Ronald van Haren (pressh) - Tuesday, 03 August 2010, 07:56 GMT
okay if that command isn't working then something is going wrong. does it give any errors or such?

is DBUS_SESSION_BUS_ADDRESS exported for you ?
is ksmserver running ('ps aux | grep ksmserver' or similar) ?
does it happen with a clean user profile ?
Comment by Panos Filip (Flamelab) - Tuesday, 03 August 2010, 18:10 GMT
1. Regarding DBUS_SESSION_BUS_ADDRESS:

Yes it is exported.

flamelab@prometheus ~ $ export | grep DBUS_SESSION_BUS_ADDRESS
declare -x DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-47NfkFCcez,guid=da1bb2a8792117e86b33d2ef00000018"

and

2. ksmserver

flamelab@prometheus ~ $ ps aux | grep ksmserver
flamelab 3815 0.0 0.0 3872 292 ? S 21:06 0:00 kwrapper4 ksmserver
flamelab 3816 0.0 0.6 380116 26672 ? Sl 21:06 0:00 kdeinit4: ksmserver [kdeinit]
flamelab 4810 0.0 0.0 8344 960 pts/1 S+ 21:08 0:00 grep --colour=auto ksmserver


The user profile is exactly one month old.

What should I try ? A new .kde4 or a new user ?
Comment by Panos Filip (Flamelab) - Tuesday, 03 August 2010, 18:12 GMT
Ah, I forgot: that command you had written doesn't have any output at all.

flamelab@prometheus ~ $ qdbus org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout 1 2 2

flamelab@prometheus ~ $



(and I see no windows or anything displayed after running that)
Comment by Ronald van Haren (pressh) - Wednesday, 04 August 2010, 07:03 GMT
try whatever is more convenient for you, just make sure you can role back if you want to so you don't lose your configs. 4.5.0 will hit the repos soon so you may also want to try if it magically fix it for you.
Comment by Ronald van Haren (pressh) - Wednesday, 04 August 2010, 07:07 GMT
one more thing which may help tracking down where this comes from, can you see if the logout thing exists at all in the ksmserver via qdbusviewer (part of qt package). it should be somewhere under ksmserver -> ksmserverinterface
Comment by Panos Filip (Flamelab) - Wednesday, 04 August 2010, 07:07 GMT
For the record, I tried the easiest (to use a new .kde4 - I justed mv'ed .kde4 to .kde4backup), and the problem stayed.

I 'll try:

1)Creating a new use
2)Using GDM
2b)Using gdm-old
3)Starting kde from xinitrc

It seems to be a KDE related issue though, even though it seems to be more widespread (I know some users who have that problem with KDE, I'll tell them to make a post here in order to have more views on that issue.)

Also, except for shutdown, reboot and logout don't work. BUT Suspend to ram works (haven't tried suspend to disk)
Comment by Panos Filip (Flamelab) - Wednesday, 04 August 2010, 07:08 GMT
(sorry for the mistake)
1)Creating a new user*
Comment by Ionut Biru (wonder) - Wednesday, 04 August 2010, 07:16 GMT
gdm-old is useless because is not compatible with polkit
Comment by Panos Filip (Flamelab) - Wednesday, 04 August 2010, 09:53 GMT
More news on the issue:

Reboot/shutdown/logout prompt window works on Xfce4 and GNOME (with their correspondent tools of course)

(it still doesn't for KDE)

Well, there is a problem: the issue is "resolved" if I create a new user and login with that ! Then, it seems to be an issue in my user's dotfiles. Since having a new .kde4 doesn't help, then the issue where should it be located ?
Comment by Panos Filip (Flamelab) - Wednesday, 04 August 2010, 10:11 GMT
More news:

I logged into my normal account.
The issue seems to be located within ~/.config

I mv'ed .config to .config-bak (so that i'll have a new one in the next login) and the problem seems to be "solved" !

The directory's contents are:

flamelab@prometheus ~/.config $ ls
0ad autostart chromium Dolezel Google mousepad QSpeedTest smplayer tint2 xfce4
akonadi awesome Clementine emesene1.0 libfm nautilus qtcurve Terminal Trolltech.conf xfce4-session
aurploader Bespin compiz gnormalize menus pcmanfm ristretto Thunar vlc

(That is actually good news, since it doesn't seem to be an actual direct KDE problem)

Comment by Ronald van Haren (pressh) - Wednesday, 04 August 2010, 10:27 GMT
[removed my message as it was wrt to your previous message]

can you try if it is related to the akonadi folder, it's seems to be the only one which may influence anything in kde as you already ruled out the themes by using a clean .kde4.
Comment by Panos Filip (Flamelab) - Wednesday, 04 August 2010, 11:01 GMT
There is a highly strange paradox:

deleting akonadi/ (the only KDE related directory) doesn't do something (the problem is still there).

Moving/deleting the whole .config, solves the issue.

:S

Loading...