Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20273 - [iana-etc] rpcbind fails to bind to socket

Attached to Project: Arch Linux
Opened by Dave Reisner (falconindy) - Sunday, 25 July 2010, 00:56 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 04 August 2010, 07:59 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

I apologize for the seemingly counterintuitive summary, but I'm not sure how to accurately describe the core of this issue.

rpcbind starts successfully, but shows the following errors in dmesg:

Jul 24 20:34:42 quake rpcbind: cannot get local address for udp: Servname not supported for ai_socktype
Jul 24 20:34:42 quake rpcbind: cannot get local address for tcp: Servname not supported for ai_socktype

The end result is that my nfs shares (v3, not sure about v4) are failing to mount. Removing iana-etc and rolling back to filesystem-2010.02 fixes the problem.

Not sure where to start debugging this, as the layout of the /etc/services file provided with the iana-etc package varies significantly from the old /etc/services included with filesystem-2010.02.
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 04 August 2010, 07:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  rpcbind-0.2.0-2
Comment by Ivan Yurasov (vanDake) - Sunday, 25 July 2010, 19:00 GMT
one solution is provided at https://bbs.archlinux.org/viewtopic.php?pid=797824#p797824

$ diff -Naur /etc/services tmp/services
--- /etc/services 2010-07-24 03:10:40.000000000 +0400
+++ tmp/services 2010-07-25 12:37:27.278819259 +0400
@@ -405,8 +405,10 @@
pop3 110/tcp # Post Office Protocol - Version 3
pop3 110/udp # Post Office Protocol - Version 3
# Marshall Rose <mrose&dbc.mtview.ca.us>
-sunrpc 111/tcp # SUN Remote Procedure Call
-sunrpc 111/udp # SUN Remote Procedure Call
+rpcbind 111/tcp
+rpcbind 111/udp
+#sunrpc 111/tcp # SUN Remote Procedure Call
+#sunrpc 111/udp # SUN Remote Procedure Call
# Chuck McManis <cmcmanis&freegate.net>
mcidas 112/tcp # McIDAS Data Transmission Protocol
mcidas 112/udp # McIDAS Data Transmission Protocol


second is add alias to sunrpc as rpcbind
Comment by Dave Reisner (falconindy) - Sunday, 25 July 2010, 19:27 GMT
This works for me. I opted to leave sunrpc alone and add rpcbind as an alias to sunrpc, i.e.:

-sunrpc 111/tcp # SUN Remote Procedure Call
-sunrpc 111/udp # SUN Remote Procedure Call
+sunrpc 111/tcp rpcbind # SUN Remote Procedure Call
+sunrpc 111/udp rpcbind # SUN Remote Procedure Call

Same (good) end result.
Comment by Thomas Bächler (brain0) - Tuesday, 27 July 2010, 22:35 GMT
This is a bug in rpcbind: The name assigned by the IANA is 'sunrpc', not 'rpcbind'. The rpcbind package should honor the official IANA names.
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 03 August 2010, 19:53 GMT
This should be fixed in rpcbind-0.2.0-2 please test. Thanks.
Comment by Dave Reisner (falconindy) - Tuesday, 03 August 2010, 20:59 GMT
Confirmed, fixed.

Loading...