Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20218 - [ossp] /dev stuff isn't made without extra work.

Attached to Project: Community Packages
Opened by Frozen Fox (FrozenFox) - Monday, 19 July 2010, 05:33 GMT
Last edited by Jan Alexander Steffens (heftig) - Saturday, 28 August 2010, 08:54 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Default install doesn't seem to work properly. /dev/dsp, /dev/adsp, and /dev/mixer are supposed to be made by ossp, but weren't for me. Looking at a how-to for fedora ( http://fedoraproject.org/wiki/Features/OSSProxy ), I seem to have found out why and it is fixed by some small manual stuff which I think could/should be added to the pkgbuild.

Additional info:

ossp 1.3.2-7

Steps to reproduce:

Just install and run ossp as-is.

Steps to resolve:

groupadd cuse
modprobe cuse
usermod -aG cuse YOUR_USER

Of course, the audio group needed to be made and assigned to the user too as per the fedora how-to, but I'm pretty sure those are default/obvious settings for arch.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Saturday, 28 August 2010, 08:54 GMT
Reason for closing:  Not a bug
Comment by Jan Alexander Steffens (heftig) - Monday, 19 July 2010, 12:16 GMT
Did you start osspd using the rc.d script?
Comment by Frozen Fox (FrozenFox) - Monday, 19 July 2010, 12:38 GMT
Yes, it's the first and only way I have started ossp. That didn't work for me.

..Perhaps that didn't work properly because the cuse group didn't exist yet? It certainly didn't, because I remember looking for it in my groups file and not finding it anywhere. I see that the start script references modprobe cuse, so I suppose that's extraneous information now. Is modprobe supposed to create that group? I expect not since the fedora how-to tells you to modprobe and then add the group later, but I don't know. I think I have a third machine to test this on, and I will post back when I get the chance.
Comment by Frozen Fox (FrozenFox) - Monday, 19 July 2010, 13:03 GMT
Weird. I tested it on a third machine, and unlike the first two, it had no problems making the aforementioned /dev stuff. My guess is some quirk in my configuration I overlooked with the first two.

For the record, on the third machine after a reboot with the daemon enabled, there is no cuse group as the fedora wiki recommends (lsmod shows it is active though), and as such naturally my user isn't in it. Testing it out, that doesn't seem to matter unless my laptop has hardware mixing going on that I'm unaware of; multiple streams with oss seem to run properly at the same time with ossp handling them. I'm not sure if anything else would cause problems without that, but I expect not at this point.

My apologies for the waste of time, and I suppose this should be closed.
Comment by Jan Alexander Steffens (heftig) - Monday, 19 July 2010, 16:20 GMT
Arch isn't using a cuse group. /dev/cuse should only be accessible to root.

Loading...