Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#20216 - German translation confusing

Attached to Project: Pacman
Opened by Johannes Höhn (slint) - Sunday, 18 July 2010, 21:52 GMT
Last edited by Dan McGee (toofishes) - Thursday, 02 September 2010, 13:00 GMT
Task Type Bug Report
Category i18n & l10n
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 3.4.0
Due in Version 3.4.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
When updating packages or installing packages pacman displays the total download size and the total installed size.
In the German translation this is written in the past like the packages already would have been downloaded and installed.
Also the German translation lacks the alignment of the sizes.

English version:

Total Download Size: 0,01 MB
Total Installed Size: 0,05 MB

German version:

Gesamtgröße der heruntergeladenen Pakete: 0,01 MB
Gesamtgröße der installierten Pakete: 0,05 MB

In my opinion better:

Gesamtgröße der zu herunterladenden Pakete: 0,01 MB
Gesamtgröße der zu installierenden Pakete: 0,05 MB
This task depends upon

Closed by  Dan McGee (toofishes)
Thursday, 02 September 2010, 13:00 GMT
Reason for closing:  Fixed
Comment by Johannes Höhn (slint) - Monday, 19 July 2010, 16:33 GMT Comment by Dan McGee (toofishes) - Monday, 26 July 2010, 03:40 GMT
Can you submit a patch to the po file? It is available in git, or you can even go over to http://www.transifex.net/projects/p/archlinux-pacman/c/pacman/, grab the translation, and submit changes.
Comment by Pierre Schmitz (Pierre) - Wednesday, 28 July 2010, 21:35 GMT
This sounds somehow wrong. Your translation uses an active term; but the packages don't download themselves. Better would be "herunterzuladenden" and "zu installierenden". However, this translation is still strange.

Can we assign this somehow to Matthias as he has taken care of the German translation for some years?
Comment by Matthias Gorissen (Matthias_Gorissen) - Thursday, 29 July 2010, 07:41 GMT
Confirmed - this is a bug. On the other hand, pacman often uses very short expressions -"Total Installed Size" instead of "Total size of packages that will be installed". So we should strive for clarity while avoiding grammatical awkwardness.

In this case we could use "Gesamtgröße des Downloads", since every German-speaking user will understand "Download" (by now).
And "Gesamtgröße der zu installierenden Pakete", yes.

But that is a minor issue to be fixed after the next string-freeze (mental note to myself). I wouldn't bother about a patch right now.
Comment by Matthias Gorissen (Matthias_Gorissen) - Thursday, 02 September 2010, 10:47 GMT
Fixed for 3.4.1.

Loading...