Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20199 - [texlive-core] dvisvgm segfaults on any dvi

Attached to Project: Arch Linux
Opened by Vladimir (_v_l) - Saturday, 17 July 2010, 02:05 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Tuesday, 28 September 2010, 15:19 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Francois Charette (Firmicus)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The dvisvgm coming with texlive-core (testing) segfaults on any dvi file.

Steps to reproduce:
1. Complite the attached file with latex
2. Run dvisvgm on test4dvisvgm.dvi


P.S. I didn't install the whole texlive (testing) packages but try only dvisvgm from texlive-core.

Besides that I compiled dvisvgm from HG repo and it segfaults too if gcc-4.5.0 was used. I already faced with the fact that gcc 4.5.0 is (too) "buggy" so I installed gcc 4.4.4 in parallel and dvisvgm compiled with gcc-4.4.4 don't segfault.
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Tuesday, 28 September 2010, 15:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 2010.1
Comment by Francois Charette (Firmicus) - Monday, 19 July 2010, 08:24 GMT
Confirmed (on x86_64). I'll enquire upstream (TeX Live and dvisvgm) about this.

Edit: see https://sourceforge.net/tracker/?func=detail&aid=3031498&group_id=145640&atid=762580
Comment by Rémy Oudompheng (remyoudompheng) - Tuesday, 20 July 2010, 04:27 GMT
Moving around the declaration of GraphicPath::WriteActions in GraphicPath members seems to workaround the problem. I have no idea why. Only tested with raw dvisvgm 1.0.2 from souceforge, not the TeXLive version.
Comment by Rémy Oudompheng (remyoudompheng) - Tuesday, 28 September 2010, 15:19 GMT
This was fixed by a gcc update, texlive-bin 2010.1 no longer shows the issue.

Loading...