Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20049 - Providing vi support by vim package

Attached to Project: Arch Linux
Opened by Vladimir (_v_l) - Friday, 02 July 2010, 02:24 GMT
Last edited by Ionut Biru (wonder) - Saturday, 03 July 2010, 13:24 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Some programs use vi as default editor (like sudo) but there is no such program and there is no package that provides it. I suggest that vim package would provide vi as a link vi->vim.
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 03 July 2010, 13:24 GMT
Reason for closing:  Not a bug
Comment by xduugu (xduugu) - Friday, 02 July 2010, 08:56 GMT
Not sure if it applies to all of the programs you have in mind, but for visudo you can set VISUAL/EDITOR to vim in .bashrc.
Comment by Vladimir (_v_l) - Friday, 02 July 2010, 11:04 GMT
Yes. Use of EDITOR could help of course.
But please note that sudo, crontab and others call vi as default, may be because of that:
http://www.opengroup.org/onlinepubs/009695399/utilities/vi.html
So, simply, it must be there.
Comment by Eric Belanger (Snowman) - Friday, 02 July 2010, 14:23 GMT
There is a vi package in core.
Comment by Vladimir (_v_l) - Friday, 02 July 2010, 23:41 GMT
Thanks Eric, I didn't notice vi package :)

Actually I like vim much more than original vi so I stay with EDITOR=vim

Loading...