Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20046 - [module-init-tools] add depmod.d configuration dir

Attached to Project: Arch Linux
Opened by Devin J. Pohly (djpohly) - Thursday, 01 July 2010, 19:47 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 04 December 2011, 04:54 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Aaron Griffin (phrakture)
Thomas Bächler (brain0)
Dave Reisner (falconindy)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
depmod(8) man page mentions a depmod.d configuration dir that is similar to modprobe.d. We include one in the package, but not the other. Filed as a feature since nothing breaks without depmod.d... but then, nothing breaks without modprobe.d either. It would just be nice to know that depmod configuration "officially" exists in more than just depmod.conf(5).

Additional info:
* module-init-tools 3.11.1-2, or latest svn

Steps to reproduce:
* pacman -S module-init-tools
* Look for /etc/depmod.d/
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 04 December 2011, 04:54 GMT
Reason for closing:  Implemented
Additional comments about closing:  module-init-tools 3.16-3
Comment by Devin J. Pohly (djpohly) - Friday, 30 July 2010, 18:33 GMT
If you need an example of where this could be useful, consider the tp_smapi package. It builds a modified version of the kernel's `hdaps' module (it hasn't been upstreamed for various reasons) which is compatible with tp_smapi and places it in $MODDIR/extra. A file /etc/depmod.d/tp_smapi.conf could prioritize this module above the built-in one, allowing Arch's normal module-loading mechanism to choose the correct version. This file could simply be added to the tp_smapi package, and depmod run at package install/uninstall.

Again, I realize you could do the same thing without depmod.d existing beforehand, but it is good to know the option is there (and modprobe.d is a precedent).
Comment by Thomas Bächler (brain0) - Friday, 30 July 2010, 18:46 GMT
There is /lib/modules/.../updates that exists exactly for that purpose. I didn't even know you could configure depmod, and never saw the need to do so.
Comment by Allan McRae (Allan) - Friday, 30 July 2010, 23:21 GMT
The documentation provided with the package indicates that these files should be present so I think they should be installed even if empty and of little use.
Comment by Devin J. Pohly (djpohly) - Saturday, 31 July 2010, 01:46 GMT
The updates subdirectory didn't exist either (should kernel26 create one?), but it worked when I created it. Knowing now about that, I agree that depmod.d is of very little use (though depmod.conf may still come in handy for the odd sysadmin). However, I also agree with Allan's reasoning, since upstream appears to intend that these files exist. If we were to decide this feature is pure cruft, it would behoove us to convince upstream of that as well.

(By the way, I touched up http://wiki.archlinux.org/index.php/Kernel_Module_Package_Guidelines with a short bit about the updates subdirectory. I'd appreciate it if someone more official than I could give it a look-see.)
Comment by Thomas Bächler (brain0) - Saturday, 31 July 2010, 08:40 GMT
I'm not saying we shouldn't add depmod.d, just stating that there is a less complex mechanism for your problem.
Comment by Dave Reisner (falconindy) - Tuesday, 15 November 2011, 13:41 GMT
Time to dust this off now that we're forcing users to have an extramodules dir. depmod.conf is deprecated in the same way modprobe.conf is, so it seems fairly straightforward to provide something like /etc/depmod.d/arch.conf with "search updates extramodules built-in".
Comment by Mark (voidzero) - Thursday, 24 November 2011, 15:10 GMT
Coincidentally I found a use case for a file in /etc/depmod.d/ -- archlinux' linux package provides modules that are also provided by xtables_addons, so I am trying to set the /lib/modules/`uname -r`/extra dir to a higher preference. No luck so far, but that's because I'm fairly new at this.
By the way, there is nothing called /lib/modules/`uname -r`/**/updates.

Loading...