Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20004 - dosbox: error while loading shared libraries: libmodplug.so.0

Attached to Project: Arch Linux
Opened by Aner (argent0) - Monday, 28 June 2010, 01:39 GMT
Last edited by Ionut Biru (wonder) - Monday, 28 June 2010, 11:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

dosbox: error while loading shared libraries: libmodplug.so.0: cannot open shared object: No such file or directory

Additional info:
* package version(s)
dosbox-0.74-1
* config and/or log files etc.


Steps to reproduce:
try to run dos box in a terminal

Workaround:
Compile using ABS
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 28 June 2010, 11:39 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Monday, 28 June 2010, 08:50 GMT
dosbox 0.74-1 doesn't link to libmodplug.so.0

/usr/bin/dosbox -- libSDL_sound-1.0.so.1
/usr/bin/dosbox -- libasound.so.2
/usr/bin/dosbox -- libpthread.so.0
/usr/bin/dosbox -- libSDL-1.2.so.0
/usr/bin/dosbox -- libpng14.so.14
/usr/bin/dosbox -- libz.so.1
/usr/bin/dosbox -- libSDL_net-1.2.so.0
/usr/bin/dosbox -- libX11.so.6
/usr/bin/dosbox -- libGL.so.1
/usr/bin/dosbox -- libstdc++.so.6
/usr/bin/dosbox -- libm.so.6
/usr/bin/dosbox -- libgcc_s.so.1
/usr/bin/dosbox -- libc.so.6
Comment by Ionut Biru (wonder) - Monday, 28 June 2010, 08:52 GMT
be sure your system is fully up to date
Comment by Ionut Biru (wonder) - Monday, 28 June 2010, 10:52 GMT
can you please upload the log of this command:

LD_DEBUG=files dosbox > log 2>&1

note that you need to revert whatever you did to the stock packages
Comment by Aner (argent0) - Monday, 28 June 2010, 11:12 GMT
afaik, My system is up to date, according to pacman -Syu and Mirror status
i'm using mir.archlinux.fr with last update Mon 28 Jun 2010 11:01:07 AM CEST

   log (4.4 KiB)
Comment by Ionut Biru (wonder) - Monday, 28 June 2010, 11:23 GMT
pacman -Qi sdl_sound
Comment by Aner (argent0) - Monday, 28 June 2010, 11:37 GMT
aner@susi:dosbox [0,914,39]$ pacman -Qi sdl_sound
Name : sdl_sound
Version : 1.0.3-2
URL : http://icculus.org/SDL_sound/
Licenses : LGPL
Groups : None
Provides : None
Depends On : sdl libmikmod libvorbis flac speex smpeg
Optional Deps : None
Required By : dosbox
Conflicts With : None
Replaces : None
Installed Size : 464,00 K
Packager : Unknown Packager
Architecture : i686
Build Date : jue 12 nov 2009 02:39:06 ART
Install Date : jue 12 nov 2009 02:43:46 ART
Install Reason : Explicitly installed
Install Script : No
Description : A library to decode several popular sound file formats, such as .WAV and .MP3
Comment by Ionut Biru (wonder) - Monday, 28 June 2010, 11:39 GMT
that's not from us and is a version built i guess by you or fetched from an unsupported repository.

please use sdl_sound from extra

Loading...