Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19968 - Upgrading pacman fails because of pacman-color (and conversely)

Attached to Project: Arch Linux
Opened by Luck Darnière (LuX) - Friday, 25 June 2010, 09:45 GMT
Last edited by Allan McRae (Allan) - Friday, 25 June 2010, 10:14 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

---> Description:

Dependency loop (or something like that) between pacman and pacman-color results in:
- 'pacman -S pacman' fails because of pacman-color
- 'pacman -S pacman-color' fails because of pacman

I had to remove pacman-color first (pacman -R -n pacman-color) before upgrading pacman and then re-installing pacman-color.

---> Additional info: package version(s)

[root@mercure /]# yaourt -Ss pacman
core/pacman 3.4.0-2 [3.3.3-5 installé] (base)
A library-based package manager with dependency support
core/pacman-mirrorlist 20100621-1 [20100131-1 installé]
Arch Linux mirror list for use by pacman
[..]
archlinuxfr/pacman-color 3.4.0-1 [3.3.3-1 installé]
Command-line frontend for libalpm aka pacman with color patch

---> Steps to reproduce
** English translation of the error messages and comments inserted by myself**

[root@mercure /]# pacman -S pacman-color
:: Les paquets suivants devraient être mis à jour en premier :
** The following packages sould be updated first: **
pacman
:: Voulez-vous annuler l'opération courante et
:: mettre à jour ces paquets maintenant? [O/n]
** I typed <Enter>, so that pacman should update pacman (default choice) **

Résolution des dépendances...
Recherche des conflits possibles entre paquets...
Erreur: la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
** Error: preparation of the transaction failed (the satsifaction of dependencies failed)
:: pacman-color: requiert pacman=3.3.3
** 'requiert' is 'requires' or 'required' in english, I believe **

[root@mercure /]# pacman -S pacman
Résolution des dépendances...
Recherche des conflits possibles entre paquets...
Erreur: la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: pacman-color: requiert pacman=3.3.3
** Same translation as above **


This task depends upon

Closed by  Allan McRae (Allan)
Friday, 25 June 2010, 10:14 GMT
Reason for closing:  Not a bug
Additional comments about closing:  We do not support pacman-color. Remove it.

Loading...