Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19879 - xf86-video-nouveau "/etc/X11/xorg.conf.d/20-nouveau.conf" request

Attached to Project: Arch Linux
Opened by susurration (susurration) - Monday, 21 June 2010, 00:05 GMT
Last edited by Jan de Groot (JGC) - Monday, 21 June 2010, 06:29 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After installing the xf86-video-nouveau driver Xorg experienced a fatal sever error of no screens found. The reason that this occurs is because the installation process of the xf86-video-nouveau driver lacks a key element: the auto creation of the "20-nouveau.conf" file in "/etc/X11/xorg.conf.d/" directory.


Additional info:
* package version: extra/xf86-video-nouveau 0.0.16_git20100517-1

* config and/or log files: http://pastebin.org/346541

Steps to reproduce:

Just install xf86-video-nouveau driver and startX


Solution:

Create a file named "20-nouveau.conf" in "/etc/X11/xorg.conf.d/" and fill it with:

Section "Device"
Identifier "nvidia"
Driver "nouveau"
EndSection

After applying the above solution Xorg has no errors, as can be seen from this Xorg log: http://pastebin.org/346557

It would be nice to see this solution implemented as an automatic configuration feature in the install process of this driver, and thus is a feature request.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 21 June 2010, 06:29 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Adding this file to xorg.conf.d configures the nouveau driver whenever this driver is installed. This is not wanted behaviour.
Comment by Andreas Radke (AndyRTR) - Monday, 21 June 2010, 04:52 GMT
I don't think it's esential to predefine the driver though almost everybody will do it anyways. The Fedora pkg maintained by an upstream dev also doesn't ship such a conf file.

What's in your Xorg.0.log without any configuration file?

Loading...