FS#19854 - --ignore is ignored

Attached to Project: Pacman
Opened by Taylan Ulrich B. (taylanub) - Friday, 18 June 2010, 15:53 GMT
Last edited by Allan McRae (Allan) - Saturday, 05 February 2011, 11:41 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version 3.4.0
Due in Version 3.4.3
Due Date Undecided
Percent Complete 100%
Votes 12
Private No


The --ignore option doesn't seem to work.
Tried IgnorePkg and IgnoreGroup in pacman.conf too; they don't work either.

P.S.: PUN!
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 05 February 2011, 11:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  pacman-3.4.3
Comment by Allan McRae (Allan) - Saturday, 19 June 2010, 01:44 GMT
> pacman -Su --ignore mkinitcpio
:: Starting full system upgrade...
warning: mkinitcpio: ignoring package upgrade (0.6.5-1 => 0.6.6-1)
there is nothing to do

Can you post the "--debug output". My guess is that another package is forcing the install as a dep.
Comment by Taylan Ulrich B. (taylanub) - Saturday, 19 June 2010, 15:46 GMT
Oh, i only tested it with a group installation.
(Seems to work with -Su.)

My command:
pacman -Sd games --ignore gate88 --debug

(Chose a tiny group and disabled dep-checking to keep the output brief.)

The attachment shows the stdout.

I also tried with adding 'gate88' to IgnorePkg in the config file, and the *sole* difference is this line:
debug: config: IgnorePkg: gate88
(Appearing where it's expected, after the line mentioning SyncFirst, since it's prior to IgnorePkg in the config file.)
   pmdebug0 (5.5 KiB)
Comment by Dan McGee (toofishes) - Saturday, 19 June 2010, 16:15 GMT
As you can see by your last comment, you left out a critical piece of information in the original bug report. Please don't guess at the problem if you aren't sure, include exact commands and output from the get-go next time.

It does appear that our groups handing doesn't honor ignore directives anymore. You can see this in the standard arch repos too:

dmcgee@galway ~
$ pacman -Sg rox-desktop
rox-desktop mime-editor
rox-desktop rox-lib

dmcgee@galway ~
$ sudo pacman -S rox-desktop --ignore mime-editor
resolving dependencies...
looking for inter-conflicts...
Targets (2): rox-lib-2.0.5-1 mime-editor-0.5-1

Culprit: b4317a740ac2d4f5e4d1aa56a97171c52be70d02
Reason: _alpm_sync_pkg() never errors out with PM_ERR_PKG_IGNORED; we don't check ignore lists at all in there.
Comment by Peter Bui (pnutzh4x0r) - Tuesday, 12 October 2010, 03:12 GMT
I think all you have to do is check alpm_pkg_should_ignore. Attached is a patch that makes libalpm honor the ignore flag with the rox-desktop. example.
Comment by Dan McGee (toofishes) - Tuesday, 12 October 2010, 13:16 GMT
This does break a pactest, however- sync021. The idea is right but I'm not sure the implementation is in the right spot- I believe we used to prompt in this case, for instance.

I think we have a solution to this going on  FS#19853 , as we kind of screwed up groups in 3.4.x in a lot of small ways that none of us realized.
Comment by Xavier (shining) - Tuesday, 19 October 2010, 20:26 GMT
Breaking a pactest is bad when the pactest makes sense. sync021 is debatable.
I would actually find it nicer if it correctly ignored package without the prompt.

Peter patch should be fine, it's probably how I meant to write this code originally.
But we can also just apply two patches from Jakob :
http://github.com/schuay/pacman-arch/commit/7891073c6a817474f4eeb5b84350d720420d2502 (simple refactoring)
http://github.com/schuay/pacman-arch/commit/eeb0f68b652719ad0746d26233a2df13031ef7d4 (handle --ignore with a prompt)

Sorry for the trouble, I am quite unhappy I let this go through, and that this bug remained all this time without any fixes.
 FS#19853  is especially bad because it happened together with this one, and this was never supposed to happen.
I hope we can fix this bug in maint as quickly as possible.
About  FS#19853 , we might make the situation better in master for a next major release.
Comment by Jakob Gruber (schuay) - Friday, 04 February 2011, 11:40 GMT
I think this one can be closed:

p -S rox-desktop --ignore mime-editor
:: mime-editor is in IgnorePkg/IgnoreGroup. Install anyway? [Y/n] n
warning: skipping target: mime-editor
resolving dependencies...
looking for inter-conflicts...

Targets (1): rox-lib-2.0.5-3

Total Download Size: 0.13 MB
Total Installed Size: 0.94 MB

Proceed with installation? [Y/n]
Comment by Dan McGee (toofishes) - Friday, 04 February 2011, 21:51 GMT
Is this with 3.4.3? I assume so, but just want to make sure before I close it out.
Comment by Jakob Gruber (schuay) - Saturday, 05 February 2011, 09:33 GMT