Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#19853 - No prompting about groups

Attached to Project: Pacman
Opened by Taylan Ulrich B. (taylanub) - Friday, 18 June 2010, 15:45 GMT
Last edited by Allan McRae (Allan) - Tuesday, 01 February 2011, 04:03 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To Dan McGee (toofishes)
Architecture All
Severity High
Priority Normal
Reported Version 3.4.0
Due in Version 3.5.0
Due Date Undecided
Percent Complete 100%
Votes 46
Private No

Details

When i do `pacman -S <group>`, it acts as if i had listed each group member on the command line.
There's no message given telling it's a group, or a question asked if i want to install the whole content, etc..
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 01 February 2011, 04:03 GMT
Reason for closing:  Implemented
Additional comments about closing:  In git: http://projects.archlinux.org/pacman.git /commit/?id=00fec5e2
Comment by Tom (hungerfish) - Monday, 05 July 2010, 11:37 GMT
Same goes when removing a group. Basically the hole group gets removed, the -s switch is ignored.
See http://bbs.archlinux.org/viewtopic.php?pid=786667#p786667
Comment by Roman Kyrylych (Romashka) - Friday, 17 September 2010, 07:18 GMT
@Dan: is it a regression, or something has changed without notice?
Comment by Roman Kyrylych (Romashka) - Friday, 17 September 2010, 12:38 GMT
raising this to High because it is not possible to skip some package from the group with --ignore, so installing only some parts of a group has become quite tricky now
Comment by Allan McRae (Allan) - Friday, 17 September 2010, 13:59 GMT
@Roman: the group handling code was deliberately removed from the libalpm backend with pacman-3.4.0 as it would be better to take place in the frontend. However, none of the regular pacman developers have the motivation to get it into the frontend and no-one else has provided a patch...
Comment by Allan McRae (Allan) - Friday, 17 September 2010, 14:00 GMT
also --ignore with packages in a group should work with pacman-3.4.1.
Comment by Dan McGee (toofishes) - Friday, 17 September 2010, 14:17 GMT
Roman, you are describing  FS#19854  in your most recent comment.
Comment by Roman Kyrylych (Romashka) - Monday, 20 September 2010, 11:07 GMT
@Allan: that's bad, this was not even mentioned in NEWS file
And --ignore doesn't work in 3.4.1:
$ pacman -Sgq xorg
xf86-video-vesa
xorg-server
xf86-video-vesa
xorg-docs
xorg-fonts-100dpi
xorg-fonts-75dpi
xorg-res-utils
xorg-server
xorg-server-utils
xorg-twm
xorg-utils
xorg-xinit
xterm
$ pacman -Sp xorg | wc -l
77
$ pacman -Sp xorg --ignore xterm | wc -l
77

So now we have one useful feature completely broken. :-(
Comment by Jakob Gruber (schuay) - Friday, 24 September 2010, 19:11 GMT
I've been working on implementing this. Please check my changes for viability/errors before I send this to the pacman-dev ML:

http://github.com/schuay/pacman-arch/commits/group_backend
Comment by Assaf Sapir (meijin) - Tuesday, 12 October 2010, 14:34 GMT
when this bug will close? this is really annoing bug :(

Loading...