Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19838 - [grub2] Include EFI support

Attached to Project: Arch Linux
Opened by Erwin Van de Velde (evdvelde) - Thursday, 17 June 2010, 14:55 GMT
Last edited by Ronald van Haren (pressh) - Friday, 28 January 2011, 22:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
  • Anonymous Submitter (2010-08-16)
Private No

Details

Description:
For users who want to install grub2 on a Mac computer or laptop, EFI support should be enabled in order to detect OSX.

Additional info:
* package version(s)
grub2 1.98-4

* config and/or log files etc.
More info: http://grub.enbug.org/TestingOnMacbook
This task depends upon

Closed by  Ronald van Haren (pressh)
Friday, 28 January 2011, 22:04 GMT
Reason for closing:  Implemented
Additional comments about closing:  should hopefully work with the extra efi packages supplied with grub2 1.99rc
Comment by Anonymous Submitter - Thursday, 01 July 2010, 18:05 GMT
For grub2 compiled for EFI systems, you can try the AUR grub2-efi-bzr AUR package http://aur.archlinux.org/packages.php?ID=40290 .

If you want grub2's built-in efi runtime support for loading Mac's XNU kernel directly in grub2 (for bios, in native grub2 EFI there is no efiemu), then pass "--enable-efiemu" to configure (requires gcc-multilib).
Comment by Anonymous Submitter - Monday, 16 August 2010, 18:09 GMT
I don't mind if some TU wants to move these packages from AUR to extra or community repo and maintain it. I also maintain the bzr versions of these packages in AUR - please don't move/delete them.
Comment by Anonymous Submitter - Saturday, 25 September 2010, 06:23 GMT
--EDIT--

Download the official packages from testing repo. skodabenz-arch-grub2-$arch repos will not be maintained.

Loading...