Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19833 - Pidgin does not run on amd64 - wrong ELF class

Attached to Project: Arch Linux
Opened by Börje Holmberg (linfan) - Wednesday, 16 June 2010, 23:16 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 17 June 2010, 04:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:pidgin refuses to load on amd64
with following error


$ pidgin
pidgin: error while loading shared libraries: libidn.so.11: wrong ELF class: ELFCLASS32

Additional info:
* package version(s)
* config and/or log files etc.
Name : pidgin
Version : 2.7.1-1
Packager : Ionut Biru <ibiru@archlinux.org>
Architecture : x86_64

Steps to reproduce:
type pidgin in term window
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 17 June 2010, 04:44 GMT
Reason for closing:  Works for me
Comment by Ionut Biru (wonder) - Wednesday, 16 June 2010, 23:46 GMT
/usr/lib/libidn.so.11 is owned by libidn 1.16-1

you messed up your system. reinstall libidn, check pacman.conf /etc/pacman.d/mirrorlist (links to point to x86_64)

Loading...