Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19806 - (i686) Some of programs not working after upgrading glibc and binutils ( segmentation fault )

Attached to Project: Arch Linux
Opened by webnull (webnull) - Tuesday, 15 June 2010, 14:39 GMT
Last edited by Allan McRae (Allan) - Wednesday, 16 June 2010, 03:50 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After upgrading glibc and binutils some of programs cant start, for example k3b, kdenlive and wine.

Logs from valgrind:
http://wklej.org/id/350806/
http://wklej.org/id/350807/

Additional info:
glibc 2.12-2
binutils 2.20.1-3


Steps to reproduce:

How to fix:
http://schlunix.org/archlinux/core/os/
Downgrade glibc to: glibc-2.11.1-3
Downgrade binutils to: binutils-2.20.1-2
This task depends upon

Closed by  Allan McRae (Allan)
Wednesday, 16 June 2010, 03:50 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See comments
Comment by Allan McRae (Allan) - Tuesday, 15 June 2010, 23:27 GMT
==4012== at 0x6E8E0FA: ??? (in /usr/lib/libc-2.11.1.so)
==4012== by 0x6E8DBC9: ??? (in /usr/lib/libc-2.11.1.so)


Something is screwy on your system
Comment by Allan McRae (Allan) - Wednesday, 16 June 2010, 03:50 GMT
valgrind log show you have a mixture of glibc versions on your system and in strange places (libc-*.so should be in /lib and not /usr/lib). This is something you have done to yuor system.

Loading...