Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19799 - [gdm] /etc/pam.d/gdm to allow passwordless functionality in Gnome!!

Attached to Project: Arch Linux
Opened by trusktr (trusktr) - Tuesday, 15 June 2010, 08:45 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 03 May 2011, 12:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
The following line (without quotes) is missing from /etc/pam.d/gdm:
"auth sufficient pam_succeed_if.so user ingroup nopasswdlogin"
This line should go directly after the line containing "pam_env.so" (I **think** this is the best spot for it, correct me if I'm wrong :).


Additional info:
* package version(s): The latest from the repos for gnome
* config and/or log files etc.


Steps to reproduce:
With the current Gnome setup from the repos, simply attempt to enable passwordless login with users-admin tool (System > Administration > Users and Groups) and you will see that it doesn't work. ;)

More info can be found on this post that I made in the forums:
http://bbs.archlinux.org/viewtopic.php?pid=773159#p773159

Please let me know if you need any more details! :)

(I've attached my /etc/pam.d/gdm file so you can see what it looks like with the extra line.)
   gdm (0.7 KiB)
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 03 May 2011, 12:27 GMT
Reason for closing:  Not a bug
Additional comments about closing:  see the last comments
Comment by trusktr (trusktr) - Tuesday, 15 June 2010, 09:23 GMT
Hey guys, for reference, here is the default /etc/pam.d/gdm file from gnome.org:
http://git.gnome.org/browse/gdm/tree/data/gdm
Comment by Jan de Groot (JGC) - Wednesday, 16 June 2010, 07:38 GMT
We don't have a nopasswdlogin group in our distribution, so you need to create that anyways.
Comment by trusktr (trusktr) - Wednesday, 16 June 2010, 07:46 GMT
Wouldn't it be nice to have it? Is there any reason not to have it?

It took me weeks to figure out how to get nopasswdlogin working with gnome!
Comment by trusktr (trusktr) - Wednesday, 23 June 2010, 15:29 GMT
I think that Arch should have a nopasswdlogin group available (but not used) by default so that if someone installs gnome, the appropriate features would work or someone else can find their own use for it.

But at least provide the correct lines in gdm or common-auth for PAM so that enabling password-bypass in Gnome works like it is supposed to. Nothing happens unless the user manually patches PAM, which could get annoying!

Now, the question is, does PAM come default with Arch when you install [core]? if so, i understand that you want to keep the distro as lite as possible, but i think the functionality of potential future apps that users install is very important for Arch reptation.

Users should be able to choose and pick what they want on their system, then once it's installed, it should work to the fullest extent possible. A user can then *unpatch* anything he so wishes from the app(s) he has installed.

I had to search around for WEEKS to figure out how to fix this simple problem! At least I learned something though ;)

If anything, there should at LEAST be firm documentation on this in the Arch Wiki for Gnome or for the Beginner's Guide, etc. (i might just have to add it myself! :D )
Comment by Jonathan Garbee (Garbee) - Friday, 02 July 2010, 19:17 GMT
I think it would be best just to make a Wiki page for this issue. This is simply a convenience feature, nothing major.

Also why install more than necessary during install? You are saying to install things and let people un-install it if they don't want it. Why not let people just install what they want/need?

"Arch Linux defines simplicity as without unnecessary additions, modifications, or complications, and provides a lightweight UNIX-like base structure that allows an individual user to shape the system according to their own needs. In short: an elegant, minimalist approach." From http://wiki.archlinux.org/index.php/The_Arch_Way .
Comment by trusktr (trusktr) - Monday, 05 July 2010, 06:17 GMT
yeah definitely, i get what you mean. I might just have to add the wiki page on this if no one else does before i get to it! It took me a while to figure this out so it would definitely help others.

I found tons of pages on google of people finding "workarounds" to the problem, but nothing like this until a guy from gnome told me the correct way to do it, so i'll definitely have to do my part to contribute :D
Comment by JM (fijam) - Monday, 02 May 2011, 18:19 GMT
Looks like the nopasswdlogin group will not be added by default so perhaps this bug can be closed?
Comment by trusktr (trusktr) - Tuesday, 03 May 2011, 08:50 GMT
Sure. By the way, I've already added the relevant info to the Wiki.

Loading...