Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19787 - [kernel26-lts] Riptide sound cards do not work in 2.6.32-lts

Attached to Project: Arch Linux
Opened by Gary James (gazj) - Sunday, 13 June 2010, 19:01 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 19 November 2010, 18:07 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Riptide sound cards do not work in kernel 2.6.32-lts, they did in 2.6.27-lts. Please see outputs below. The /dev/snd devices are not crated


2.6.32-lts
----------

lsmod|grep '^snd' | column -t
snd_seq_dummy 1067 0
snd_riptide 16290 0
snd_seq_oss 24824 0
snd_seq_midi_event 4452 1 snd_seq_oss
snd_seq 41361 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_ac97_codec 87815 1 snd_riptide
snd_pcm_oss 33090 0
snd_mixer_oss 13619 1 snd_pcm_oss
snd_pcm 57255 3 snd_riptide,snd_ac97_codec,snd_pcm_oss
snd_opl3_lib 7126 1 snd_riptide
snd_timer 15309 3 snd_seq,snd_pcm,snd_opl3_lib
snd_hwdep 4624 1 snd_opl3_lib
snd_page_alloc 5777 2 snd_riptide,snd_pcm
snd_mpu401_uart 4883 1 snd_riptide
snd_rawmidi 14863 1 snd_mpu401_uart
snd_seq_device 4317 5 snd_seq_dummy,snd_seq_oss,snd_seq,snd_opl3_lib,snd_rawmidi
snd 41122 13 snd_riptide,snd_seq_oss,snd_seq,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device

ls -l /dev/snd
total 0
crw-rw---- 1 root audio 116, 3 Jun 13 12:31 seq
crw-rw---- 1 root audio 116, 2 Jun 13 12:31 timer



and in 2.6.27-lts
-----------------

root@reddwarf ~ $ lsmod|grep '^snd' | column -t
snd_seq_dummy 4612 0
snd_seq_oss 31616 0
snd_seq_midi_event 8320 1 snd_seq_oss
snd_seq 49584 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 38528 0
snd_mixer_oss 16000 1 snd_pcm_oss
snd_riptide 23828 2
snd_ac97_codec 99108 1 snd_riptide
snd_pcm 69892 4 snd_pcm_oss,snd_riptide,snd_ac97_codec
snd_opl3_lib 11392 1 snd_riptide
snd_timer 21768 3 snd_seq,snd_pcm,snd_opl3_lib
snd_hwdep 8964 1 snd_opl3_lib
snd_page_alloc 9480 2 snd_riptide,snd_pcm
snd_mpu401_uart 8832 1 snd_riptide
snd_rawmidi 21632 1 snd_mpu401_uart
snd_seq_device 8332 5 snd_seq_dummy,snd_seq_oss,snd_seq,snd_opl3_lib,snd_rawmidi
snd 50980 16 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_riptide,snd_ac97_codec,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device

root@reddwarf ~ $ ls -l /dev/snd
total 0
drwxr-xr-x 2 root root 60 Jun 13 19:56 by-path
crw-rw---- 1 root audio 116, 7 Jun 13 19:56 controlC0
crw-rw---- 1 root audio 116, 3 Jun 13 19:56 hwC0D0
crw-rw---- 1 root audio 116, 4 Jun 13 19:56 midiC0D0
crw-rw---- 1 root audio 116, 6 Jun 13 19:56 pcmC0D0c
crw-rw---- 1 root audio 116, 5 Jun 13 19:57 pcmC0D0p
crw-rw---- 1 root audio 116, 8 Jun 13 19:56 seq
crw-rw---- 1 root audio 116, 2 Jun 13 19:56 timer

Steps to reproduce:

Upgrade from kernel 2.6.27-lts to 2.6.32-lts and issue command ls -l /dev/snd to see if devices exist
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 19 November 2010, 18:07 GMT
Reason for closing:  Won't fix
Additional comments about closing:  patch is known but not of major interest - not allowed to apply by Arch patching rules, no response from the user for months
Comment by Andreas Radke (AndyRTR) - Saturday, 17 July 2010, 11:12 GMT
It seems all modules are loaded well. Please check dmesg output for differences. Maybe it's also caused by a bug or incompatibility in udev. You can try udev-compat.
Comment by Andreas Radke (AndyRTR) - Saturday, 14 August 2010, 22:02 GMT
state? there were lots of lts updates. if it's still not solved please report it upstream.
Comment by Gary James (gazj) - Sunday, 15 August 2010, 15:49 GMT
Unfortunately still the same. I will report it upstream as long as it is not something to do with the way the arch kernel build options.
Comment by Gary James (gazj) - Sunday, 15 August 2010, 16:05 GMT Comment by Gary James (gazj) - Sunday, 15 August 2010, 19:33 GMT
Applied patch as suggested at https://bugzilla.kernel.org/show_bug.cgi?id=16596

Bug fixed. No doubt this will now be fixed in the next upstream release. Patch and modified PKGBUILD attatched for those interested until such time.
Comment by Andreas Radke (AndyRTR) - Friday, 29 October 2010, 10:48 GMT
Is this solved in the recent 2.6.32.25 release? If not you should get in touch with upstream stable team.

Loading...