Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers

FS#19625 - 2010.05 Snapshots regression: not bootable on HP Probook 5310m (USB flashdisk install)

Attached to Project: Release Engineering
Opened by LX (gimmeapill) - Friday, 28 May 2010, 11:57 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 30 July 2011, 20:39 GMT
Task Type Bug Report
Category Hardware Issues
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 2010.05
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No


The 2010.05 snapshots freeze one of my notebooks (I tried i686, x64, dual, for core and netinst).

The problematic machine is an HP Probook 5310m:

when I plug in the USB flashdisk, it simply cause a complete lockup (whether or not an operating system is already running),
and the computer has to be reset with the power button.

The led on the flashdisk blinks like if there was a disk access, but at this stage the keyboard doesn't respond anymore.
I cannot get any trace as there is no operating system installed

I don't think it is an installation problem on my side, as the 2010.05 medias work fine on the other machines I tried them on (with the same USB flasdisk). And I cannot try to boot from CD either as this model doesn't have any optical drive.

On the other hand, the 2009.08 installation medias worked fine on this machine, and the Arch Linux installation didn't cause any particular problem. So this really makes me think that one of the changes with the new installation medias is incompatible with the BIOS of this machine.

The only particularity that I can think of that could be relevant to the issue is that this model has a traditional BIOS but can also boot from an EFI partition, as decribed in the HP support document below:
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 30 July 2011, 20:39 GMT
Reason for closing:  No response
Comment by Kamil (kamillus7) - Friday, 04 June 2010, 11:41 GMT
I can confirm, I have exact same problem on HP/Compaq 615 with USB and CD. Note that also the same behavior is with Chakra and OpenSuse, while Ubuntu and previous Arch ISO (Grub version and isolinux) booted normal.
Comment by Gerardo Exequiel Pozzi (djgera) - Thursday, 01 July 2010, 01:31 GMT
Please try any of these images [#1], they are based on rc version of syslinux 4.00 maybe works again...

Comment by Kamil (kamillus7) - Saturday, 03 July 2010, 11:20 GMT
Tried those images, but still the same. When it tries to boot, caps lock blinks and nothing happens.
Comment by LX (gimmeapill) - Thursday, 08 July 2010, 21:12 GMT
Yes, the problem is still there - the new images are unbootable on some machines. I'll try some other distros and let you know
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 12 July 2010, 03:48 GMT
Can you do a simple test? This not is how .iso images are created but at least can test if you get a syslinux prompt. Then take a usb-key and overwrite with this .img.

$ dd if=/dev/zero of=test.img bs=1M count=1
$ mkfs.vfat test.img
$ syslinux test.img

:( Can you contact syslinux maintainer? Maybe can debug this issue a bit?
Comment by LX (gimmeapill) - Wednesday, 14 July 2010, 07:36 GMT
Hi Gerardo,
I made the test and no, even with the latest syslinux (4.01) they still don't boot.
(I could reproduce also with the Debian Live USB creation procedure
But there's still one thing I don't understand: why were the old (.img) installation medias working then? was it because of an older syslinux version?
Comment by Stefan Afradi (Afradi) - Saturday, 16 October 2010, 19:19 GMT
Verifying this on a ProBook 5310m.
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 16 October 2010, 20:49 GMT
OK, try to contact to the author of syslinux, or related people in the syslinux mailing list, maybe can help in find the issue and fix/workaround them.