Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19617 - [usbmuxd] 1.0.4-1 uses gid and uid 130, which are already used by pulseaudio

Attached to Project: Arch Linux
Opened by Ulf Winkelvos (uwinkelvos) - Thursday, 27 May 2010, 22:36 GMT
Last edited by Ionut Biru (wonder) - Friday, 28 May 2010, 09:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
usbmuxd 1.0.4-1: install script fails on setups that use pulseaudio, as this package already creates a user and a group with id 130

Additional info:
usbmuxd 1.0.4-1 (install script)
pulseaudio 0.9.21-6


Steps to reproduce:
1) install pulseaudio
2) install usbmuxd
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 28 May 2010, 09:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  usbmuxd 1.0.4-2
Comment by Ionut Biru (wonder) - Thursday, 27 May 2010, 22:59 GMT
this kinda sucks. i wonder why nobody added that entry in the wiki:

http://wiki.archlinux.org/index.php/DeveloperWiki:UID_/_GID_Database
Comment by Ulf Winkelvos (uwinkelvos) - Thursday, 27 May 2010, 23:30 GMT
this is indeed an interesting wiki page. I did not know it, but i guess that pulse maintainer should. Did you send him a message?!
Comment by Ionut Biru (wonder) - Thursday, 27 May 2010, 23:32 GMT
i send an email to aur-general asking in the future to add them. now i can't even use groupmod to change uid because of  FS#18516 .

i guess i have to use pre_upgrade and remove the user/group
Comment by Ulf Winkelvos (uwinkelvos) - Thursday, 27 May 2010, 23:53 GMT
i wonder why that has not been fixed in 2 month?! the patch from the gentoo guys looks pretty trivial.

Loading...