Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19603 - unzip should include iconv patch

Attached to Project: Arch Linux
Opened by Jun Wu (quark) - Thursday, 27 May 2010, 08:47 GMT
Last edited by Roman Kyrylych (Romashka) - Thursday, 27 May 2010, 09:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Non-english world (CJK characters) *really* need this patch because currently there are no other utilities properly handle this issue and there are plenty of this kind of zips (almost all in those containing non-ascii file names).

Note: unzip 6.0-4 has this patch included, while the patch is removed from unzip 6.0-5 with a reason "upstream doesn't include this patch". upstream unzip team rejected the iconv patch long before and people do need this patch, in fact unzip 5.x in major dists (include arch) include this patch.

Related topics:
https://bugs.launchpad.net/ubuntu/+source/unzip/+bug/203609
https://bugs.launchpad.net/debian/+source/unzip/+bug/10979

Note that the saying "unzip does not support UTF-8 filenames" is not accurate. unzip does support utf-8 zips created from linux world. However, zips created from linux are usually not utf-8 encoded.

Additional info:
* package version(s)
unzip 6.0-5


Steps to reproduce:
For a zip file created from non-english Windows world which contains non-utf8 non-english file names.
Unzip it, file names are not readable, or may fail due to invalid filename.

For exmaple, "tankrule.zip" from http://astardata.baidu.com/download/tankrule.zip:

% unzip tankrule.zip
Archive: tankrule.zip
inflating: Astar2010��+-��i��ۤ����=.pdf
% ls
Astar2010??+-??i??ۤ????=.pdf

If I use a version with iconv patch, say, unzip 6.0-4, I can use -O option to correctly extract this file:

% unzip -O GBK ./tankrule.zip
Archive: ./tankrule.zip
inflating: Astar2010坦克大战详细规则.pdf
% ls
Astar2010坦克大战详细规则.pdf

Recommended solution:
Reuse unzip 6.0-4 PKGBUILD and that's all.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Thursday, 27 May 2010, 09:00 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#18691 
Comment by Jun Wu (quark) - Thursday, 27 May 2010, 08:51 GMT
This issue is somehow duplicated with http://bugs.archlinux.org/task/18691

Loading...