Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19570 - [terminator] bash children do not exit when terminal is closed

Attached to Project: Community Packages
Opened by Johan R (cleanrock) - Sunday, 23 May 2010, 21:22 GMT
Last edited by Jelle van der Waa (jelly) - Saturday, 14 January 2012, 11:58 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Guillaume ALAUX (galaux)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

terminator 0.93-1

Steps to reproduce:
Start terminator and do a few splits, then close all terminals except one => you will (or at least i) see that multiple bash child processes exist.
This task depends upon

Closed by  Jelle van der Waa (jelly)
Saturday, 14 January 2012, 11:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  upstream fixed it in 0.96
Comment by Dan Griffiths (Ghost1227) - Sunday, 30 May 2010, 07:45 GMT
Can others verify this issue?
Comment by Johan R (cleanrock) - Sunday, 30 May 2010, 11:21 GMT
To clarify, when i say close i mean by mouse (right click menu -> close).
Typing exit will terminate bash.
PS. I think you as package owner can try to reproduce it.
Comment by Thomas Dziedzic (tomd123) - Saturday, 03 July 2010, 14:09 GMT
I can confirm this issue. Johan, can you please report this upstream?
Comment by Johan R (cleanrock) - Saturday, 03 July 2010, 16:13 GMT Comment by Thomas Dziedzic (tomd123) - Wednesday, 14 July 2010, 17:21 GMT Comment by Johan R (cleanrock) - Thursday, 15 July 2010, 13:25 GMT
its not fixed in 0.94, do a few splits and close with mouse and you will see
Comment by Thomas Dziedzic (tomd123) - Thursday, 15 July 2010, 13:43 GMT
can you please report this upstream (reopen their bug report)
Comment by Johan R (cleanrock) - Thursday, 15 July 2010, 16:46 GMT
Done.
I find this both amusing and a bit depressing, terminator devs said it should be fixed, both them and we could have spent one minute to verify that the problem was actually fixed :).
Open source development quality at its finest !
Comment by Thomas Dziedzic (tomd123) - Saturday, 04 September 2010, 08:15 GMT
0.95 released, probably not fixed, but worth asking
Comment by Johan R (cleanrock) - Saturday, 04 September 2010, 11:32 GMT
<snip> brb with result
Comment by Johan R (cleanrock) - Monday, 11 October 2010, 12:54 GMT
not fixed (that brb was not very quick).
Comment by Jelle van der Waa (jelly) - Saturday, 13 August 2011, 20:11 GMT
status?
Comment by Steven V (steabert) - Thursday, 18 August 2011, 21:38 GMT
I use latest terminator 0.95-4 and this issue is still there.

EDIT: having a look at the python code of terminator, it seems that when one right-clicks and chooses menu-close, the terminal is only deregistered by calling the method deregister_terminal from the terminator class. Adding the line "terminal.close()" before it is removed from the terminals list (at "self.terminals.remove(terminal)") seems to solve the problem for me.

-> I added this to https://bugs.launchpad.net/terminator/+bug/308025/comments/10
Comment by Jelle van der Waa (jelly) - Friday, 16 September 2011, 21:01 GMT
I have updated that codepath to call close() on the Terminal object, so as of r1234 in trunk this should be fixed. It will be in 0.96.
Comment by Jelle van der Waa (jelly) - Saturday, 14 January 2012, 10:42 GMT
Does 0.96 fix it?
Comment by Steven V (steabert) - Saturday, 14 January 2012, 10:46 GMT
Yes, 0.96 fixes it for me.
Comment by Johan R (cleanrock) - Saturday, 14 January 2012, 11:58 GMT
0.96 fixes it for me too.

Loading...