Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19445 - [go-openoffice] 3.2.0.9-2 has too many hard dependencies

Attached to Project: Arch Linux
Opened by Fabien COUTANT (fcoutant) - Thursday, 13 May 2010, 09:18 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 07 June 2010, 16:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The current situation is contradictory: java-runtime is listed as optional but some other packages which depend on it are mandatory.
Please help stop dependency bloat invasion in ArchLinux : hsqldb-java, beanshell, saxon and lucene should really be optdepends, not depends.
Same for vigra : it brings in ~46M of mostly unused software (with hdf5); I don't see the point in making them mandatory.

Steps to reproduce:
I repackaged manually to change the dependencies (unpack, edit .PKGINFO, repack), installed the result and it works fine, at least writer, calc and impress -- I don't use base but it should work too with odbc drivers.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 07 June 2010, 16:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  vanilla 3.2.1/go-oo 3.2.1.3 have most stuff now as optional deps. if further changes are requested please open a new bug/task.
Comment by Andreas Radke (AndyRTR) - Thursday, 13 May 2010, 10:16 GMT
If you can proof which deps are really only optdepends I might change it. Remove them and run all important parts of OOo.
Comment by Fabien COUTANT (fcoutant) - Thursday, 13 May 2010, 11:35 GMT
As I tried to explain in "Steps to reproduce", I already did it : I currently run a package which has vigra, hsqldb-java, beanshell, saxon and lucene as optdepends.
Though I forgot to mention that "draw" also works fine, what other "important parts" do you think of ?
Or what kind of proof do you want ?

Loading...