Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#19440 - [apache-ant] doen't meet Java Package Guidelines

Attached to Project: Arch Linux
Opened by Vitaliy Berdinskikh (UR6LAD) - Wednesday, 12 May 2010, 21:10 GMT
Last edited by Guillaume ALAUX (galaux) - Thursday, 17 May 2012, 11:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Guillaume ALAUX (galaux)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No


Description: apache-ant doesn't use the /usr/share/<package> folder as its home folder but use the /usr/share/java/<package> folder.

So I can't place a jar-file from my depended package apache-ivy to right place.
Place all jar files (and __no other files__) distributed with the program in a /usr/share/java/myprogram directory

I propose move apache-ant folder to /usr/share/apache-ant, make symlink /usr/share/apache-ant/lib to /usr/share/java/apache-ant where place all jars (see my apache-ant-devel in AUR).

Additional info:
* package version: 1.8.0

If you move apache-ant to AUR I can adopt it.
This task depends upon

Closed by  Guillaume ALAUX (galaux)
Thursday, 17 May 2012, 11:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 1.8.3-2
Comment by Vitaliy Berdinskikh (UR6LAD) - Monday, 14 June 2010, 21:09 GMT
In 1.8.1-1 this bug/feature still alive.
Comment by Guillaume ALAUX (galaux) - Wednesday, 07 March 2012, 20:27 GMT
Working on this. Could take some time as *a lot* of other packages could be created first.