Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#19352 - [sane] can't use my scanner since sane 1.0.21

Attached to Project: Arch Linux
Opened by Marc Cousin (cousinm) - Tuesday, 04 May 2010, 07:09 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 05 May 2010, 07:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Since I upgraded to sane 1.0.21-2, I can't use my scanner anymore. I get this error :

scanimage -d epson2:libusb:008:002 > /tmp/scan.pnm
scanimage: sane_start: Invalid argument

I get this error with every sane program I tried (xsane, quiteinsane…)

Going back to 1.0.20-5 solves the problem.

Scanner is Epson Perfection 640 U

I can provide you with a sane debug trace if required.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 05 May 2010, 07:31 GMT
Reason for closing:  Not a bug
Comment by Tobias Powalowski (tpowa) - Wednesday, 05 May 2010, 05:23 GMT
have you tried to use an other epson backend? There are imho 2 backends.
Comment by Marc Cousin (cousinm) - Wednesday, 05 May 2010, 05:55 GMT
You're right : it fails only with epson2 backend, it works with epson.

But it's the epson2 that is autodetected, so all programs try to use it.
Comment by Tobias Powalowski (tpowa) - Wednesday, 05 May 2010, 06:17 GMT
Well deactivate epson2 backend in dll.conf and all should be fine.