Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19330 - [xorg] System doesn't remember screen resolution

Attached to Project: Arch Linux
Opened by Freek (teek) - Sunday, 02 May 2010, 18:24 GMT
Last edited by Jan de Groot (JGC) - Friday, 18 May 2012, 11:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
When I reboot my htpc (atom n330 with intel graphics) and my TV (Sony Bravia (1366x768), which I use as the primary screen) is off, the system sets the desktop to 1024x768 even though I specify at every place that I know of (xorg.conf and KDE configuration area) that it should be 1280x768.

This is annoying because widgets jump around after reboots. I need the PC to boot sometimes with the screen off because it is also used as a NAS and webserver (from time to time).

I know it has something to do with my TV not giving the correct modelines when off but I just need the workspace to always be what I specify, regardless of what it detects in this case...

Additional info:
* package version(s)
Everything is current
(xorg-server-1.7.6-3, kde-4.4.2-1)

* config and/or log files etc.
My xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
DisplaySize 332 207
Modeline "1280x768_60.00" 80.14 1280 1344 1480 1680 768 769 772 795 -HSync +Vsync
# 1280x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 80.14 MHz
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x768"
EndSubSection

EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "ServerFlags"
Option "DontZap" "False"
EndSection



Steps to reproduce:
Reboot, auto-login enabled, keep TV/Screen off (TV is connected via VGA)
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 18 May 2012, 11:59 GMT
Reason for closing:  Won't fix
Comment by Freek (teek) - Monday, 26 July 2010, 15:41 GMT
It's been a while but I can now tell you that the current Ubuntu does the same thing.

When I startup with the TV off it just goes back to 1024x768.... very annoying :)
Comment by Greg (dolby) - Friday, 04 March 2011, 03:15 GMT
Is this still a problem with latest package versions? Did you report this to the xorg bugzilla?
Comment by Freek (teek) - Sunday, 06 March 2011, 12:32 GMT
It has been a while since I tested it, next week I have some time to try it again, I'll post the result here. It may well be a bug in the Bravia TV but still I think one should be able to enfore a certain resolution to be used always regardless of what a monitor tells xorg.
Comment by Freek (teek) - Saturday, 12 March 2011, 13:18 GMT
I tested it, the bug is still present. My KDE4 does not remember the desktop resolution setting over reboots, it always reverts to 1024x768 (which has "auto" behind it).
Comment by Freek (teek) - Saturday, 12 March 2011, 14:02 GMT
I now placed an executable script:

#!/bin/bash
xrandr --output VGA1 --mode 1280x768

in ~/.kde4/Autostart/

which after the splash screen sets the resolution to 1280x768. Ugly and far from optimal but for now it save me a lot of clicking.
Comment by Jan de Groot (JGC) - Monday, 03 October 2011, 13:50 GMT
You could try to add this to your kernel bootup line:

video=VGA1:1280x768-24@60

That should set 1280x768 on VGA1 at bootup. All that X does is trying to use the best mode available, it probably rejects the 1280x768 modeline from your configuration because DDC doesn't list it.

Loading...