Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19321 - [util-linux-ng|shadow] agetty -> login **problems**

Attached to Project: Arch Linux
Opened by orbisvicis (orbisvicis) - Saturday, 01 May 2010, 23:58 GMT
Last edited by Tom Gundersen (tomegun) - Saturday, 24 September 2011, 11:34 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Tom Gundersen (tomegun)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Two problems
1] agetty (util-linux-ng) takes too much time in summoning login (shadow)
. . -> text entered in agetty after submitting the username will not be forwarded to the login process (1s .. 5s .. waiting for password prompt).

2] agetty does not handle text inputted while summoning login
. . -> text entered in agetty after submitting the username will be displayed directly onto the screen (oh, look at that - password is displayed in plain text)

I'm hoping this can be solved by reconfiguring Arch, ie not a problem inherent to either of these packages.


Additional info:
* package version(s)
core/shadow 4.1.4.2-2
core/util-linux-ng 2.17.2-2


Steps to reproduce:
On a slower system, try inputting the login password immediately after submitting (pressing enter) the username. The password will be displayed. I sometimes need wait ten or more seconds before the password prompt appears.
This task depends upon

Closed by  Tom Gundersen (tomegun)
Saturday, 24 September 2011, 11:34 GMT
Reason for closing:  No response
Comment by Roman Kyrylych (Romashka) - Tuesday, 10 August 2010, 08:13 GMT
what's the status with util-linux-ng-2.18-3?
Comment by orbisvicis (orbisvicis) - Thursday, 12 August 2010, 16:56 GMT
Still problematic, unfortunately.

2] is like running "sleep 5" and entering some text while bash is waiting
1] means the new process takes too long - forever.. - to execv or fork or get created, whichever
Comment by Greg (dolby) - Friday, 04 March 2011, 03:16 GMT
Does it work now that util-linux-ng got renamed to util-linux? :)
Comment by orbisvicis (orbisvicis) - Sunday, 13 March 2011, 08:02 GMT
no this is still a problem. I've had some random thoughts though:

1] Hide input (confusing)
# stty to disable echo
stty -echo
agetty -c
# login wrapper
stty echo
trap “stty -echo” 0
login

# close output fd for agetty but not children
agetty 1>&-

2] Cache and forward input to login
??

3] start login sooner/faster
Agetty wrapper with higher nice value:
highest_priority=$(( 20 - $(ulimit -H -e) ))
highest_priority=${highest_priority:-0}
renice -n "$highest_priority" -p "$$"

-or-

fix/patch agetty
Comment by Eric Belanger (Snowman) - Saturday, 25 June 2011, 07:44 GMT
2] is not a bug. see  FS#20508 
Comment by Tom Gundersen (tomegun) - Tuesday, 30 August 2011, 21:50 GMT
10 seconds sounds like a lot, so this might be a bug in util-linux. Could there be some other reason that it is so slow? Do you have something happening in the background? What kind of computer are you using? Are you using network storage or anything like than?

Loading...