Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19276 - [xfce4-sensors-plugin] 1.0.0-1 doesn't show hddtemp data

Attached to Project: Arch Linux
Opened by indianahorst (indianahorst) - Wednesday, 28 April 2010, 13:12 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 06 June 2010, 11:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since the last update of extra/xfce4-sensors-plugin to version 1.0.0-1, it doesn't show hddtemp data.
It's definitely a problem of this version, because the version from AUR, aur/xfce4-sensors-plugin-git 20100202-1 works without problems and shows the "Hard disk" entry in dropdown menu.

For further information read the last two posts in http://bbs.archlinux.org/viewtopic.php?pid=750604

Additional info:
* package version(s)
xfce4-sensors-plugin 1.0.0-1


Steps to reproduce:
Install xfce4-sensors-plugin 1.0.0-1 and add it to your xfce4-panel. Right click on it in panel, select "Properties" and click on "Sensors type".
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 06 June 2010, 11:26 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Thursday, 29 April 2010, 11:29 GMT
I can see the hard disc sensor. Works for me.

Is the AUR package built in a different way? You can also start the plugin from a shell and watch fur useful messages.
Comment by indianahorst (indianahorst) - Thursday, 29 April 2010, 12:22 GMT
I have discovered that the AUR package works only one time - directly after it is installed.
One reboot later, the hddtemp temperature is vanished from the panel. Very strange!
Comment by indianahorst (indianahorst) - Thursday, 29 April 2010, 12:38 GMT
How can I start xfce4-sensors-plugin from command line? On the command line I only can start xfce4-sensors, and this doesn't output any messages at all.
Comment by Andreas Radke (AndyRTR) - Thursday, 29 April 2010, 19:49 GMT
xfce4-sensors should it be and may show some infos.

have you setup /etc/conf.d/hddtemp and is its daemon is running?
Comment by indianahorst (indianahorst) - Thursday, 29 April 2010, 21:06 GMT
Starting xfce4-sensors on the shell doesn't show anything.

Yes, /etc/rc.d/hddtemp is running. /etc/rc.d/sensors is running too.

$ cat /etc/conf.d/hddtemp
PARAMS="-q -l 127.0.0.1"
DRIVES="/dev/sda"

Exactly this configuration worked without problems until the last update of xfce4-sensors-plugin on March, 29.
Comment by Andreas Radke (AndyRTR) - Friday, 30 April 2010, 09:48 GMT
so hddtemp /dev/sda should bring up something.

Please check the plugin upstream code repository or ask the upstream developer. I can't confirm this. Works for me. Sometimes gtk themes cause trouble or maybe something completely different.
Comment by indianahorst (indianahorst) - Friday, 30 April 2010, 11:39 GMT
hddtemp /dev/sda works as user without problems and outputs the correct temperature.
If you had read the link above to my two posts in the forums, you would know this.
Comment by Andreas Radke (AndyRTR) - Sunday, 02 May 2010, 14:15 GMT
Still cannot confrim this. Please aks the upstream maintainer or check the git changes yourself. Maybe give a link to fololow your upstream bugreport.
Comment by Andreas Radke (AndyRTR) - Wednesday, 12 May 2010, 21:11 GMT
Maybe remove the plugin and ~/.config/xfce4/panel/xfce4-sensors-plugin configuration file/check permissions and try again. It works for me on my two Xfce systems.
Comment by Andreas Radke (AndyRTR) - Friday, 04 June 2010, 04:59 GMT
state?
Comment by indianahorst (indianahorst) - Saturday, 05 June 2010, 22:09 GMT
Okay, I think I have now finally found the problem. It's a missing dependency. Your version of xfce4-sensors-plugin doesn't depends on netcat. The version from AUR (xfce4-sensors-plugin-git) pulls in netcat and that's it why it works. Also this will be the reason why your xfce4-sensors-plugin works.

I have just found it accidentally as I executed pacman -Qdt and there was a bunch of software which wasn't required by any program. I uninstalled them all and in this moment the shown HDD temperature in the xfce panel switched to 0.0 C. So I re-installed all software again and uninstalled them one by one to get the one, which lets the HDD temperature go to zero. It was netcat.

Please correct this ASAP and insert netcat as dependency!

Loading...