Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19141 - [gtk-smooth-engine] themes don't work properly on gtk2

Attached to Project: Arch Linux
Opened by Connor Behan (connorbehan) - Saturday, 17 April 2010, 19:59 GMT
Last edited by Dan Griffiths (Ghost1227) - Wednesday, 05 May 2010, 01:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dan Griffiths (Ghost1227)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: The delightfully smooth theme (for example) looks much better as a gtk1 theme than a gtk2 theme. Many effects that are supposed to be applied are not (along with warnings printed to the console) because libsmooth.so is built for gtk1 but not gtk2. At first I thought it was just a choice by the packagers so I put it in an AUR package "gtk2-smooth-engine" but now I'm convinced it's a genuine bug that this package has had for years.


Additional info:
* Version is: gtk-smooth-engine 0.6.0.1-3
* The gtk2 version was probably omitted because of deprecated functions that don't work anymore. However it makes more sense to FIX this than ignore it.

Steps to reproduce:
* Install gtk, gtk2 and gtk-smooth-engine.
* Switch to a smooth theme for both gtk1 and gtk2.
* Run a gtk1 app from the console and run a gtk2 app from the console.
This task depends upon

Closed by  Dan Griffiths (Ghost1227)
Wednesday, 05 May 2010, 01:57 GMT
Reason for closing:  Fixed

Loading...