Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#1912 - firefox 1.0 hangs

Attached to Project: Arch Linux
Opened by Aaron Griffin (phrakture) - Saturday, 18 December 2004, 18:41 GMT
Last edited by Dale Blount (dale) - Sunday, 19 December 2004, 21:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dale Blount (dale)
Architecture not specified
Severity Medium
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

So as not to repeat too much, this forum post (http://bbs.archlinux.org/viewtopic.php?t=8659) details my issue.

Basically firefox hangs on odd pages (www.citibank.com) which are seemingly just normal html (grabbed a few with wget, nothing extraordianry). Recompiling from source, while checking out from CVS fixed it....
This task depends upon

Closed by  Dale Blount (dale)
Tuesday, 03 May 2005, 04:00 GMT
Reason for closing:  Not a bug
Additional comments about closing:  not an Arch bug at least...
Comment by Jan de Groot (JGC) - Sunday, 19 December 2004, 11:06 GMT
Do you have the new freetype 2.1.9 installed?
Comment by Aaron Griffin (phrakture) - Tuesday, 21 December 2004, 15:23 GMT
freetype 2.1.9 from testing was installed originally, after learning that changes from 2.1.7 may be causing my issues, I downgraded.
This did not fix the issues.

It is entirely possible that I have something else from testing which firefox is using....

In addition, looking at the default .mozconfig from abs, freetype is disabled and Xft is used for font lookups... I should hope changes in freetype wouldn't affect firefox then.
Comment by Aaron Griffin (phrakture) - Wednesday, 05 January 2005, 16:13 GMT
Still experienceing issues.... I *think* that using --enable-static --disable-shared may have fixed somethings... though not sure... I'll keep looking and digging...

Sometimes under WMI, firefox hard-locks my machine entierly...
Comment by Jason Chu (jason) - Thursday, 13 January 2005, 02:07 GMT
What type of sound card do you have? Do you listen to music often?

I noticed that citibank has flash on their site and I'm sure many of the other sites you have problems with have flash or java embeded in their pages. Both the flash and java plugin try to grab the OSS device when they're started. If you have a sound card like the one in my laptop, it will block until my sound card is free. This makes firefox look like it's hung, but if you stop your music, firefox gets going again.

I don't know about the hard locks though.
Comment by Aaron Griffin (phrakture) - Tuesday, 18 January 2005, 22:51 GMT
This has to do with freetype2 - I downgraded to freetype2.1.7 and it fixed everything. I then modified the pkgbuild for freetype2.1.9, tried it with a) no patches, b) only the "fix" patch, c) only the bytecode patch. Both a and b worked fine, but case c failed.

In addition, I must point out that enabling the bytecode interpreter via a patch is not needed. See my font how-to in the wiki. The bytecode interpreter can be turned on and off with a setting....
Comment by Jan de Groot (JGC) - Monday, 14 February 2005, 12:20 GMT
With the current freetype2 package, does firefox still hang? If not, then I can close this bug.
Comment by Aaron Griffin (phrakture) - Monday, 14 February 2005, 15:36 GMT
Technically I think this may have been 2 different hangs - there was a freetype issue, fixed in the current build. But hangs kept happening, and it dealt with the filesystem (dialog to select where to save, when browsing file:///some/path/, etc) - removing gnome-vfs fixed those crashes....

So it's half fixed, but gnome-vfs causes some issues still... I have to make sure not to grab it as a dependancy
Comment by Jan de Groot (JGC) - Sunday, 17 April 2005, 20:54 GMT
Does firefox 1.0.3 still hang? I can't reproduce this, I use firefox on daily basis with 4 windows and 20-30 tabs in each opened day in, day out and it isn't even laggy for me. I haven't been able to reproduce this with 1.0.2 either.
Comment by Aaron Griffin (phrakture) - Sunday, 17 April 2005, 21:12 GMT
Yeah it still happens, but it seems to be an isolated issue...
I've discovered that it has something to do with libgnome - it libgnome is installed, all the dialogs will hang the system... so I just make it a point to keep libgnome uninstalled and it works fine... in the near future I may do a full reinstall, and we'll see if something changes then
Comment by Dale Blount (dale) - Monday, 18 April 2005, 13:53 GMT
Aaron,

Please try adding a new user to your system with a clean homedir and see if it works for you.
Comment by Aaron Griffin (phrakture) - Tuesday, 03 May 2005, 00:13 GMT
Hmmm, the new user worked fine... I ended up removing my entire ~/.mozilla directory... I'd suspect a pref setting or extension from an older version - but I guess this is fixed now...
horray, I can now install libgnome if it's needed

Loading...