Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#19118 - [gnuplot] Build fails with latest PKGBUILD from -- wrong texdir

Attached to Project: Arch Linux
Opened by Leonid Isaev (lisaev) - Thursday, 15 April 2010, 20:29 GMT
Last edited by Ronald van Haren (pressh) - Monday, 11 October 2010, 09:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

When trying to makepkg gnuplot 4.4 using latest PKGBUILD, the build fails, because make tries to create /usr/share/texmf, instead of $pkgdir/usr/share/texmf-dist/...

As far as I understand, the variable TEXMFLOCAL in package() is not being recognized. It seems the right one is "texdir", so the correction to PKGBUILD, which worked for me is:

./configure --with-texdir=/usr/share/texmf-dist/tex/latex/gnuplot
make texdir=$pkgdir/usr/share/texmf-dist/tex/latex/gnuplot

I haven't checked wxgtk terminal or lisp/emacs stuff, though...

Additional info:
* package version(s)
gnuplot 4.4.0
* config and/or log files etc.
PKGBUILD
   PKGBUILD (2.2 KiB)
This task depends upon

Closed by  Ronald van Haren (pressh)
Monday, 11 October 2010, 09:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  latex support in gnuplot 4.4.2-2
Comment by Stefan Husmann (stefanhusmann) - Wednesday, 21 April 2010, 02:40 GMT
Confirmed. In german forum someone successfully build gnuplot with using DESTDIR=$pkgdir in the install step.

IMHO non-texlive-packages should not use /usr/share/texmf-dist, but /usr/share/texmf, but this is discussable.
Comment by Leonid Isaev (lisaev) - Wednesday, 21 April 2010, 16:01 GMT
I'll try the DESTDIR option.

As far as texmf-dist vs texmf goes, I have no personal preference... The reason why I used the former, is only because GP 4.2 used it. I also did some scouting of Debian -unstable/-testing package DB, and they seem to have no TeX-related stuff in their GP debs, although I can be wrong here.
Comment by Leonid Isaev (lisaev) - Saturday, 24 April 2010, 22:30 GMT
No, DESTDIR=$pkdgir doesn't work. I would like to know what PKGBUILD those guys in german forum used.

It's true that the build completes cleanly, but instead of creating $pkdgir/bin, etc. we now have $pkgdir/$pkgir/bin, etc. BUT the correct $pkgdir/usr/share/texmf/.../gnuplot!
Comment by Leonid Isaev (lisaev) - Saturday, 09 October 2010, 16:20 GMT
With 4.4.2:
TEXMFLOCAL=$pkgdir/usr/share/texmf-dist still fails with
/bin/mkdir -p "/usr/share/texmf/tex/latex/gnuplot"
/bin/mkdir: cannot create directory `/usr/share/texmf/tex/latex/gnuplot': Permission denied

However, texdir=$pkgdir/usr/share/texmf-dist does work and creates $pkgdir/usr/share/texmf-dist/*.
Comment by Leonid Isaev (lisaev) - Saturday, 09 October 2010, 16:32 GMT
BTW, in the stock package, there are no LaTeX-related files.
Also, I think that Stefan was right with /usr/share/texmf, because this is the place where other applications, like asymptote, write their stuff. So it should be texdir=$pkgdir/usr/share/texmf/tex/latex/gnuplot

Loading...