Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#19051 - [net-tools] netstat doesn't show complete addresses with ipv6 aware socket

Attached to Project: Arch Linux
Opened by Seán Connolly (januszeal) - Monday, 12 April 2010, 02:34 GMT
Last edited by Ronald van Haren (pressh) - Monday, 22 August 2011, 07:51 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No


Description: netstat -n truncates addresses
tcp 0 126 ::ffff: ::ffff:58.174.201:50430 FIN_WAIT1
tcp 0 124 ::ffff: ::ffff:78.173.17.:15398 FIN_WAIT1
tcp 0 126 ::ffff: ::ffff:58.174.201:51743 FIN_WAIT1 in the first column is incomplete, as well as everything in the second column.
I'm not sure what exactly causes the ::ffff: to appear, but I know the listening program (Unreal IRCd) was compiled with "ipv6 support", and the machine in question has ipv6 addresses.

Ubuntu, OS X, et al, have a -W flag:
-W In certain displays, avoid truncating addresses even if this causes some fields to
But this appears to be missing from Arch.

Additional info:
[januszeal@peorth:~]$ netstat -V
net-tools 1.60
netstat 1.42 (2001-04-15)
Fred Baumgarten, Alan Cox, Bernd Eckenfels, Phil Blundell, Tuan Hoang and others
* config and/or log files etc.

Steps to reproduce:
Make connection to ipv6 aware socket.
netstat -nt (or most other combination of flags)
get mostly worthless output

Marked as high severity because this makes netstat useless for viewing connected IPs on ipv6 connected systems.
This task depends upon

Closed by  Ronald van Haren (pressh)
Monday, 22 August 2011, 07:51 GMT
Reason for closing:  Works for me
Additional comments about closing:  please re-open if it still doesn't work in net-tools 1.60.20110819cvs-1
Comment by Rémy Oudompheng (remyoudompheng) - Monday, 13 June 2011, 11:25 GMT
You don't seem to be sure about what you are viewing exactly. You seem to be using the IPv6 network stack to connect to IPv4 adresses, which is very strange. Addresses in the ::ffff::/96 range are IPv4 addresses in IPv6 format.