Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#19044 - local install scripts

Attached to Project: Pacman
Opened by Matthew (piezoelectric) - Sunday, 11 April 2010, 15:36 GMT
Last edited by Allan McRae (Allan) - Sunday, 22 April 2012, 11:29 GMT
Task Type Feature Request
Category Scripts & Tools
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version 3.3.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I obviously don't expect any rapid adoption of this idea, but I'd like to document it here for discussions and (ideally) eventual triage.

It would be nice to have local install scripts -- ideally somewhere below /etc/pacman.d/ -- that can be triggered on the same actions as the normal <pkgname>.install provided with a given package. These scripts could either supplement or replace actions by the package's install scripts, ex: a variable VISIBILITY={before|replace|after}. VISIBILITY could have a global setting at the head of a file, and be overridden on a per-action basis (within pre_upgrade() for example).

Another option is to have a general dispatching script, /etc/pacman.d/dispatcher.sh, that's called with the arguments <pkgname> <action>. By default the script would simply source /etc/pacman.d/local/<pkgname>.install and execute the function <action> according to the VISIBILITY variable.


I would use this functionality to do things like rebuild modules from AUR packages after a kernel upgrade and check my filesystem for files created by a package after an install (ex: R's packages are placed under /usr, but aren't removed after an uninstall).
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 22 April 2012, 11:29 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#2985 
Comment by Xavier (shining) - Sunday, 11 April 2010, 16:34 GMT
You should read http://wiki.archlinux.org/index.php/User:Allan/Pacman_Hooks because it could also give you the functionality you need.

Loading...