Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#18999 - [xorg-server] Xfvb doesn't handle transparent pixels properly in 8-bit color mode

Attached to Project: Arch Linux
Opened by Pavel (heavyrail) - Thursday, 08 April 2010, 14:48 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 16 November 2011, 11:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Xvfb shows wrong colored (e.g. black or grey) pixels instead of transparent when 8-bit color depth is set.

Additional info:
* xorg-server
* x11vnc 0.9.9-1

Steps to reproduce:

Open terminal and issue following commands:

export DISPLAY=:1
Xvfb :1 -screen 0 640x480x8 &
openbox &
x11vnc -display :1 -bg -nopw -listen localhost

Open another (!) terminal and issue:

vncviewer localhost

You can see new VNC viewer window on the screen.
Right-click the mouse somewhere within blank area of that window.
In the drop-down menu select Editors -> GEdit, and you will see the picture similar to one in attached file.
Note that should you change 'x8' to 'x16' snippet in Xvfb command above, GEdit look become normal.
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 16 November 2011, 11:54 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Upstream won't fix it. So won't we.
Comment by Roman Kyrylych (Romashka) - Tuesday, 10 August 2010, 08:10 GMT
JGC: what to do with this one?
Looks like upstream issue.
Comment by Greg (dolby) - Friday, 04 March 2011, 05:21 GMT
Is this still a problem? Has this been reported upstream?
Comment by Pavel (heavyrail) - Friday, 04 March 2011, 07:19 GMT
Yes, it is still a problem. I reported it upstream long ago, but no one answered me there: