Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18965 - [cgmail] crashes at start

Attached to Project: Community Packages
Opened by Martin Dratva (raqua) - Monday, 05 April 2010, 11:10 GMT
Last edited by Alexander F Rødseth (xyproto) (trontonic) - Saturday, 10 December 2011, 10:48 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
cGmail notifier doest not work since Gnome was updated to 2.30. Crashes with some keyring complaint.

Additional info:

$ cgmail
** Message: secret service operation failed: Cannot get secret of a locked object
Traceback (most recent call last):
File "/usr/bin/cgmail", line 26, in <module>
a = AccountsWindow()
File "/usr/lib/python2.6/site-packages/cGmail/manager/accountswindow.py", line 56, in __init__
self.amanager = AccountManager()
File "/usr/lib/python2.6/site-packages/cGmail/lib/accountmanager.py", line 49, in __init__
self.__keyring_dict_helper = KeyringDictHelper()
File "/usr/lib/python2.6/site-packages/cGmail/lib/keyringdicthelper.py", line 96, in __init__
keyring_handler = KeyringHandler()
File "/usr/lib/python2.6/site-packages/cGmail/lib/keyringdicthelper.py", line 30, in __init__
self.__data = self.__read()
File "/usr/lib/python2.6/site-packages/cGmail/lib/keyringdicthelper.py", line 47, in __read
auth_token).get_secret()
gnomekeyring.IOError

package versions:
cgmail 0.5-3
gnome 2.3.0-1

Steps to reproduce:
just start cgmail
This task depends upon

Closed by  Alexander F Rødseth (xyproto) (trontonic)
Saturday, 10 December 2011, 10:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  Crash bug since april 2010. Moving to unsupported.
Comment by Andrea Scarpino (BaSh) - Monday, 05 April 2010, 23:42 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Category (Packages: Extra → Packages)
  • Field changed: Architecture (All → All)
  • Task assigned to Dan Griffiths (Ghost1227)
Assigned to "Community Orphan Team"
Comment by Dan Griffiths (Ghost1227) - Tuesday, 06 April 2010, 19:25 GMT
Added Wonder to list.

@Wonder: If you don't want to help with community orphans anymore, let me know.
Either way, you probably know gnome 2.3.0 better than me :P
Comment by Ionut Biru (wonder) - Tuesday, 06 April 2010, 19:32 GMT
@Dan i'm helping but please don't insult gnome :P is gnome 2.30 since 2.3 is 7 years old :D.

now back in business.

@raqua please use abs and update to 0.6.1 and see if is working.
http://launchpad.net/cgmail/0.6/0.6.1/+download/cgmail-0.6.1.tar.gz

if is not working, add to this version this patch:
http://launchpadlibrarian.net/42003712/default_keyring.patch
Comment by Ionut Biru (wonder) - Tuesday, 06 April 2010, 20:26 GMT
please test 0.6.1 from community-testing. is safe to fetch only the package from a mirror
Comment by Martin Dratva (raqua) - Tuesday, 06 April 2010, 22:09 GMT
I downloaded 0.6.1 package from community-testing. It starts, but it is unable to remember account information. When I entre this info, I can see my account twice there (gmail account), but when closing and then opening again properties window, this information is gone. Never synchronizes with gmail.
I do not know how to apply patch and right now have no time. I will try to read something about it during week and try to apply that patch.
Comment by Ionut Biru (wonder) - Tuesday, 06 April 2010, 22:20 GMT
forget about the patch. is available in 0.6.1. maybe now you only have some configurations issues. try it with fresh configuration.
Comment by Martin Dratva (raqua) - Wednesday, 07 April 2010, 06:02 GMT
I uninstalled gmail. Used locate to find cgmail related files. I removed everything (except for /var/lib/pacman/sync/community/cgmail-0.5-3 which obviously are some pacman files).

This was the result:
Phenom:/home/raqua# locate cgmail
/home/raqua/cgmail-0.6.1-1-i686.pkg.tar.xz
/var/lib/pacman/sync/community/cgmail-0.5-3
/var/lib/pacman/sync/community/cgmail-0.5-3/depends
/var/lib/pacman/sync/community/cgmail-0.5-3/desc


Reinstalled cgmail again.
Still the same result. If I add account, it is not twice there now, but cgmail keeps forgetting this info. When I close config window and open it again, that account is not there. I think it is never written to keyring as I can not find anything related to cgmail in there.

Status icon of cgmail running is present, but ps -A | grep cgmail show no result. If I try to run cgmailservice I get a response that this is already running.

Starting cgmail from CLI:
Phenom:~# cgmail

** (cgmail:17567): WARNING **: Trying to register gtype 'WnckWindowState' as enum when in fact it is of type 'GFlags'

** (cgmail:17567): WARNING **: Trying to register gtype 'WnckWindowActions' as enum when in fact it is of type 'GFlags'

** (cgmail:17567): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as enum when in fact it is of type 'GFlags'
/usr/lib/python2.6/site-packages/cGmail/manager/accountswindow.py:72: GtkWarning: Theme file for Vanilla-DMZ has no directories

self.builder2.add_from_file(UI_FILE)

** (cgmailservice:18087): WARNING **: Trying to register gtype 'WnckWindowState' as enum when in fact it is of type 'GFlags'

** (cgmailservice:18087): WARNING **: Trying to register gtype 'WnckWindowActions' as enum when in fact it is of type 'GFlags'

** (cgmailservice:18087): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as enum when in fact it is of type 'GFlags'

Comment by Ionut Biru (wonder) - Wednesday, 07 April 2010, 15:42 GMT
https://bugs.launchpad.net/cgmail/+bug/503311

seems that is fixed in 0.7 which is not released yet
Comment by Martin Dratva (raqua) - Wednesday, 07 April 2010, 16:38 GMT
I don't know, but I do not see anything there saying that it is fixed in that version, just that author is focusing on development of new version.

On the other hand, this: https://bugs.launchpad.net/cgmail/+bug/546747 and this: https://bugs.launchpad.net/ubuntu/+source/gnome-keyring-sharp/+bug/536925 hints that it could be in fact gnome's bug not a cgmail bug.
Comment by Ionut Biru (wonder) - Saturday, 10 April 2010, 10:18 GMT
probably, but i don't see the connection between gnome-keyring-sharp and cgmail.
Comment by Ionut Biru (wonder) - Thursday, 13 May 2010, 19:30 GMT
is it me or this issue was fixed? i tested today and everything is working correctly
Comment by Isaac Gallart (igallart) - Saturday, 15 May 2010, 15:00 GMT
In last version, not remember your account yet, and does not start when you boot the system (gnome), but now I can run it at least.
Comment by Thomas Dziedzic (tomd123) - Monday, 07 June 2010, 20:39 GMT
status?

UPDATE:
tested this and still getting the same error on 32bit
Comment by Thomas Dziedzic (tomd123) - Thursday, 01 July 2010, 15:32 GMT
site in the PKGBUILD should be updated to https://launchpad.net/cgmail since the current one hasn't been updated in a while (it still says 0.5 released XD)
Comment by Martin Dratva (raqua) - Saturday, 03 July 2010, 20:51 GMT
I have version 0.6.1 installed and this is not working for me.
Comment by Thomas Dziedzic (tomd123) - Saturday, 03 July 2010, 21:00 GMT
This needs to get reported upstream if you want to see it get fixed in the reasonable future.
Comment by Ionut Biru (wonder) - Saturday, 03 July 2010, 21:01 GMT
can you describe now what is not working?
Comment by Martin Dratva (raqua) - Saturday, 03 July 2010, 21:05 GMT
I believe it is reported already and should be fixed in 0.7 version. If I remember correct.

What is not working:

- starting from CLI results in segmentation fault, but starting from menu works (???)
- when I start service and set it to use gnome keyring, it will not sync with gmail
- after closing the GUI and reopening, my account is not there
Comment by roko (roko) - Saturday, 18 June 2011, 19:29 GMT
what is the status of cgmail 0.6.2?
Comment by Jelle van der Waa (jelly) - Saturday, 13 August 2011, 20:11 GMT
status?
Comment by Alexander F Rødseth (xyproto) (trontonic) - Wednesday, 26 October 2011, 15:06 GMT
Here's what I get when I run cgmail (from community/cgmail 0.6.2-4):

** (cgmail.py:4564): WARNING **: Trying to register gtype 'WnckWindowState' as enum when in fact it is of type 'GFlags'

** (cgmail.py:4564): WARNING **: Trying to register gtype 'WnckWindowActions' as enum when in fact it is of type 'GFlags'

** (cgmail.py:4564): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as enum when in fact it is of type 'GFlags'
Traceback (most recent call last):
File "/usr/share/cgmail/cgmail.py", line 49, in <module>
a = AccountsWindow()
File "/usr/share/cgmail/cGmail/manager/accountswindow.py", line 58, in __init__
self.amanager = AccountManager()
File "/usr/share/cgmail/cGmail/lib/accountmanager.py", line 51, in __init__
self.__keyring_dict_helper = KeyringDictHelper()
File "/usr/share/cgmail/cGmail/lib/keyringdicthelper.py", line 106, in __init__
keyring_handler = KeyringHandler()
File "/usr/share/cgmail/cGmail/lib/keyringdicthelper.py", line 30, in __init__
self.__data = self.__read()
File "/usr/share/cgmail/cGmail/lib/keyringdicthelper.py", line 39, in __read
keyring = gnomekeyring.get_default_keyring_sync()
gnomekeyring.IOError

x86_64
Comment by Allan McRae (Allan) - Saturday, 10 December 2011, 10:15 GMT
Don't assign to me... I will just remove the package from the repo to "fix" the issue.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Saturday, 10 December 2011, 10:17 GMT
Allan, just saw you were "last packager". Removing the package seems like a fine solution to me, since this bug has been here since 05 April 2010.

Loading...