AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#18958 - $() and `` command substitutions are not displayed correctly

Attached to Project: AUR web interface
Opened by quantax (quantax) - Sunday, 04 April 2010, 10:55 GMT
Last edited by Lukas Fleischer (lfleischer) - Friday, 21 January 2011, 06:31 GMT
Task Type Bug Report
Category PKGBUILD Parser
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 1.6.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

The $() and `` command substitutions are not parsed and displayed correctly.

Especially in the source array this is very ugly: http://aur.archlinux.org/packages.php?ID=26998

You probably do not want to run the command substitutions on the server. But it would be nice if they were just displayed without any expansion.

Thus source=("http://$(echo a | sed "s/a/b/" )/") would be diplayed as http://$(echo a | sed s/a/b/ ") without running the command substitution but parsing whitespace correctly.
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Friday, 21 January 2011, 06:31 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dupe of  FS#15043 .
Comment by Gavin Bisesi (Daenyth) - Wednesday, 14 April 2010, 17:18 GMT
There's a limit to how much you can make it without implementing a full bash parser. The short answer is "Don't do that".

It also breaks the style guidelines and makes the package less readable in general.
Comment by Lukas Fleischer (lfleischer) - Tuesday, 12 October 2010, 12:21 GMT
I guess this should either be closed as "WONTFIX" (since this cannot be implemented without implementing a full bash parser, as Daenyth already said) or changed to a feature request in which case it might be a dupe of  FS#15043 .

Loading...