Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18872 - [jre] missing system preferences folder

Attached to Project: Community Packages
Opened by Leandro Costa (lokidarkeden) - Monday, 29 March 2010, 15:53 GMT
Last edited by Dan Griffiths (Ghost1227) - Monday, 29 March 2010, 20:33 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Dan Griffiths (Ghost1227)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: The package do not include the folder /etc/.java/.systemPrefs. This folder is needed to use Java viewer toolkit on UNIX-based systems.



Additional info:
* package version(s) jre 6u18-1
* config and/or log files etc.


Steps to reproduce:
Run the java administrator tool: /opt/java/bin/ControlPanel, in the advanced tab, expand the option Java Console and mark Show Console, click the ok button.
Open the website: www.bb.com.br, in the top there's two fields ( agencia, conta) and a OK button, click the button.
The site loads and the console opens, so you will see the error "java.util.prefs.FileSystemPreferences$3 run WARNING: Could not create system preferences directory. System preferences are unusable. "

This task depends upon

Closed by  Dan Griffiths (Ghost1227)
Monday, 29 March 2010, 20:33 GMT
Reason for closing:  Implemented
Comment by Denis A. Altoe Falqueto (denisfalqueto) - Monday, 29 March 2010, 16:03 GMT
Just to add some argument to implement this, the system preferences directory is a policy of the distribution. It really should be handled by the installation script of the JRE, but it is not (maybe because there could be other implementations of the Preferences API).

The solution is to add

mkdir -p /etc/.java/.systemPrefs
chmod 755 /etc/.java/.systemPrefs

to the PKGBUILD.

Loading...