Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18863 - grep 2.6+ segfaults with recursive and exclude-dir

Attached to Project: Arch Linux
Opened by Jan Steffens (heftig) - Sunday, 28 March 2010, 04:20 GMT
Last edited by Allan McRae (Allan) - Monday, 29 March 2010, 22:33 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Reproduce using:
grep -r --exclude-dir=foo bar .

Affects both i686 and x86_64.

Bug is already known and a fix commited:
http://git.savannah.gnu.org/cgit/grep.git/commit/?id=54d55bba41f2ff31682fe6523ef6f49b37a0e20f
I propose releasing a 2.6.1-2 with the above patch, unless 2.6.2 is already released.

Works:
grep 2.5.4-3

Segfaults:
grep 2.6-1
grep 2.6.1-1
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 29 March 2010, 22:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.6.2-1 in [testing]
Comment by Allan McRae (Allan) - Monday, 29 March 2010, 04:18 GMT
It looks like there are a few fixes being made to 2.6.1 and a testing snapshot has been made so it is likely that 2.6.2 will appear tomorrow.
Comment by Greg (dolby) - Monday, 29 March 2010, 21:06 GMT
GNU grep 2.6.2 is released which fixes this

Loading...