Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18860 - [devtools] removing java-runtime / java-enviroment with makechrootpkg

Attached to Project: Arch Linux
Opened by Jelle van der Waa (jelly) - Saturday, 27 March 2010, 17:59 GMT
Last edited by Allan McRae (Allan) - Saturday, 27 March 2010, 18:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When building a package with makechrootpkg and the dependency is java-runtime or java-enviroment makechrootpkg can't remove it because it's not found. Which is logical because it should remove openjdk or jre.
Since pacman -S java-runtime installs openjdk or jre it's not easy to implement it.

Additional info:
* devtools 0.9.5
*

Steps to reproduce:
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 27 March 2010, 18:41 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#15144 
Comment by Allan McRae (Allan) - Saturday, 27 March 2010, 18:41 GMT
Nothing to do with devtools. This is a makepkg limitation:  FS#15144 .

Loading...