Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18832 - [qt] 4.6.1-1 missing mesa

Attached to Project: Arch Linux
Opened by Ike Devolder (BlackEagle) - Thursday, 25 March 2010, 18:24 GMT
Last edited by Ionut Biru (wonder) - Friday, 26 March 2010, 09:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Qt supports 3d effects via libgl, but some stuff is provided by mesa for gl support


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:

build a qt application like clementine as it is in AUR then you wil get an error on some GL/gl.h stuff
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 26 March 2010, 09:51 GMT
Reason for closing:  Not a bug
Comment by Ike Devolder (BlackEagle) - Thursday, 25 March 2010, 18:47 GMT
sorry, typo, qt-4.6.2-1
Comment by Pierre Schmitz (Pierre) - Thursday, 25 March 2010, 19:26 GMT
Could you specify your exact problem? If you are missing some headers to build clementine add mesa to its makedepends. I don't see any problem with the qt package atm.
Comment by Ike Devolder (BlackEagle) - Thursday, 25 March 2010, 20:54 GMT
idd there are some missing headers for clementine, but how comes qt has 3d accell( gl ) support and then some apps need mesa and some dont?
Comment by Pierre Schmitz (Pierre) - Thursday, 25 March 2010, 21:05 GMT
it's a makedepends for qt.
Comment by Ike Devolder (BlackEagle) - Friday, 26 March 2010, 05:49 GMT
so it has to be a makedepends for clementine too then

Loading...