AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#18764 - Can't upload any new packages anymore

Attached to Project: AUR web interface
Opened by Rorschach (Rorschach) - Saturday, 20 March 2010, 19:12 GMT
Last edited by Ionut Biru (wonder) - Saturday, 20 March 2010, 20:59 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version 1.6.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,
I can't upload any new packages anymore. The packages are fine and working, they have been created with makepkg --source. But when I upload them via the webform, the webform reappears with the message:

Package URL is missing a protocol (ie. http:// ,ftp://)

The packages doesn't get uploaded to aur.
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 20 March 2010, 20:59 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Saturday, 20 March 2010, 20:19 GMT
i just tested and i don't have any problem. what is the type of your tarball?
Comment by Rorschach (Rorschach) - Saturday, 20 March 2010, 20:48 GMT
It is a tar.gz archive (see the attachment) created by makepkg --source of this PKGBUILD:

# Contributor: Rorschach <r0rschach@lavabit.com>

pkgname=archup
pkgver=1.1
pkgrel=1
pkgdesc="Small and lightweight update-notifier for archlinux."
url="https://"
arch=('i686' 'x86_64')
license="GPL"
depends=('pacman' 'libnotify')
makedepends=('libnotify' 'autoconf')
source=(http://bazaar.launchpad.net/%7Er0rschach/%2Bjunk/archup/download/r0rschach%40lavabit.com-20100320180744-y0jw6cure6t9l3pw/archup1.1.tar.gz-20100320180743-4r662d1lv6l8v8f1-1/$pkgname-$pkgver.tar.gz)
md5sums=('f1c5d4946c9e0f212a776818e8594415')

build() {
cd src
autoconf || return 1
./configure || return 1
make || return 1
install -Dm755 archup $pkgdir/usr/bin/archup
install -Dm744 README $pkgdir/usr/share/doc/archup/README
install -Dm744 INSTALL $pkgdir/usr/share/doc/archup/INSTALL
install -Dm744 COPYING $pkgdir/usr/share/doc/archup/COPYING
install -Dm744 VERSION $pkgdir/usr/share/doc/archup/VERSION
install -Dm744 cronhourly.example $pkgdir/usr/share/doc/archup/cronhourly.example
}
Comment by Ionut Biru (wonder) - Saturday, 20 March 2010, 20:52 GMT
ok is because in url var you got only https://. please add the full url
Comment by Rorschach (Rorschach) - Saturday, 20 March 2010, 20:53 GMT
Here's a screenshot of the site which appears after I try to submit a new package.
Comment by Rorschach (Rorschach) - Saturday, 20 March 2010, 20:58 GMT
Yes you are right this was the problem! After correcting this, the submission worked. But mabye this bugreport isn't totally useless and the message could state more clear what the problem is.
Comment by Ionut Biru (wonder) - Saturday, 20 March 2010, 20:59 GMT
imo the message is clear.

Loading...