Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18762 - [ghc] 6.12.1-3 in testing is still linked against libgmp.so.3

Attached to Project: Arch Linux
Opened by Skottish (skottish) - Saturday, 20 March 2010, 18:15 GMT
Last edited by Ionut Biru (wonder) - Tuesday, 23 March 2010, 17:56 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Vesa Kaihlavirta (vegai)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

GHC 6.12.1-3 in testing is still linked against libgmp.so.3 instead of libgmp.so.10.

Steps to reproduce:

ldd /usr/lib/ghc-6.12.1/ghc
This task depends upon

Closed by  Ionut Biru (wonder)
Tuesday, 23 March 2010, 17:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  in GHC 6.12.1-4
Comment by Vesa Kaihlavirta (vegai) - Sunday, 21 March 2010, 08:32 GMT
In fact this should be linked against to gmp at all, due to being compiled with integer-simple. But seems like something's not working right in the build process.
Comment by Skottish (skottish) - Sunday, 21 March 2010, 14:15 GMT
There seems to be some strangeness going on with the GHC linker in general. It looks like most to all Haskell packages on my system are linked to gmp, even xmonad-{contrib,utils}. When I updated to testing, everything broke.
Comment by Pierre Schmitz (Pierre) - Sunday, 21 March 2010, 14:33 GMT
You should always use makechrootpkg to build packages. This avoids problems with broken build systems.
Comment by Vesa Kaihlavirta (vegai) - Sunday, 21 March 2010, 15:31 GMT
ghc is built at pkgbuild.com with makechrootpkg.
Comment by Ionut Biru (wonder) - Monday, 22 March 2010, 23:41 GMT
ghc 6.12.1-3.1 is still linking.

/usr/bin/hp2ps libgmp.so.3
/usr/lib/ghc-6.12.1/unlit libgmp.so.3
Comment by Ionut Biru (wonder) - Tuesday, 23 March 2010, 01:42 GMT
i managed to rebuild it. tomorrow morning i'll do i686 and upload both archs. but even you changed to integer-simple is still linking to gmp.

/usr/bin/hp2ps libgmp.so.10
/usr/lib/ghc-6.12.1/unlit libgmp.so.10
Comment by Skottish (skottish) - Tuesday, 23 March 2010, 03:38 GMT
My copy is also linked against libgmp.so.10. Of course this is only the first step. xmonad, darcs, and lots of other things are totally broken without a rebuild.

Comment by Allan McRae (Allan) - Tuesday, 23 March 2010, 06:10 GMT
> You should always use makechrootpkg to build packages. This avoids problems with broken build systems.

That does not work this time as ghc requires ghc to build so required the old libgmp libraries to still be installed on the system. But the package should have been rebuilt against itself in a chroot afterwards.


I would be happy for this to just be rebuilt against the new gmp rather than trying to use integer-simple instead just so we can get the rebuild finished. Other changes can be addressed later. According to the thread on the bbs, there also appears to be issues with other packages when using integer-simple instead of gmp.
Comment by Vesa Kaihlavirta (vegai) - Tuesday, 23 March 2010, 06:31 GMT
All righty then. Well, if nothing else, this integer-simple build, even if slightly lacking (hp2ps and unlit) allows us to make the actual rebuild.

Thanks ghc :-/

Loading...