Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18735 - Kernel26: free more than tfds_in_queue (0:1)

Attached to Project: Arch Linux
Opened by John Gerritse (ReaphSharc) - Thursday, 18 March 2010, 08:15 GMT
Last edited by Ionut Biru (wonder) - Monday, 10 May 2010, 21:46 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:
After I upgraded the kernel26 package to version 2.6.32.10-1, this message started to pop up over 50 times a second in /var/log/everything.log:
kernel: iwlagn 0000:14:00.0: free more than tfds_in_queue (0:1)

My wireless works fine, so the only problem this creates is a rapidly growing logfile and an inability for the user to keep an eye on the logfile (any other messages are drowned in the huge amount of iwl* errors.

There is a topic on this on the forums: http://bbs.archlinux.org/viewtopic.php?id=93302
So other users with other wireless cards have the same problem.

There is a patch, at least for iwlwifi, http://www.spinics.net/lists/linux-wireless/msg47806.html
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 10 May 2010, 21:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.6.33 kernel
Comment by Micael Capitão (MiCap) - Thursday, 18 March 2010, 21:17 GMT
Same problem here on arch x86_64 with kernel 2.6.32.10-1, but I have connection problems.
After the upgrade, my wireless connection dies 5 seconds(or less) when I try to contact the outside.
Comment by Jacob Svensson (jaqob) - Friday, 19 March 2010, 22:48 GMT
I'm having similar problems.
Using iwl4695 and 2.6.32.10-1 my connection dies after 5 seconds if using WPA2 AES.
Using WPA TKIP everything works fine. I had no problems before the kernel upgrade.
Comment by Philip Dubois (heazky) - Saturday, 20 March 2010, 11:02 GMT
I can confirm this. Logfile fills up and connection dies after a couple of seconds (iwl4695).
Comment by Philip Dubois (heazky) - Saturday, 20 March 2010, 17:15 GMT
(double post)
Comment by Jacob Svensson (jaqob) - Tuesday, 23 March 2010, 21:10 GMT
Any leads yet?
Comment by Joël Schaerer (lardon) - Saturday, 27 March 2010, 19:17 GMT
Same problem here. This post (http://www.mail-archive.com/ubuntu-bugs@lists.ubuntu.com/msg2133370.html ) seems to indicate that the issue has been fixed upstream, or at least on ubuntu.

In any case, I hope the problem gets fixed fast, because having to manually clear the logs daily gets old very fast!
Comment by George (slinkygn) - Sunday, 28 March 2010, 15:05 GMT
Actually, the link in the OP patches the symptom, not the actual problem.

The followup ( http://www.spinics.net/lists/linux-wireless/msg47998.html ) is the patch that was ACK'd for commit upstream.
Comment by Wael Nasreddine (eMxyzptlk) - Saturday, 03 April 2010, 23:09 GMT
I was wondering WHY pm-suspend stopped working today, well logs were 10G :O and there was no space left on /var.. so my vote...
Comment by Wael Nasreddine (eMxyzptlk) - Wednesday, 07 April 2010, 21:01 GMT
Just to save people some time searching, apply this patch to 2.6.32 and voilà No more hangups!

P.S: I take absolutely no credit for the patch! I'm just delivering it here for easy access to people searching for a solution to the same problem!
Comment by John Gerritse (ReaphSharc) - Friday, 09 April 2010, 14:37 GMT
Upgrading to 2.6.33 solved the problem for me.
Comment by Jacob Svensson (jaqob) - Friday, 09 April 2010, 15:30 GMT
2.6.33 solved it for me as well.

Loading...