Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18708 - [gstreamer] Cannot play "mod" files after latest updates.

Attached to Project: Arch Linux
Opened by Francisco Pina (Stunts) - Tuesday, 16 March 2010, 14:28 GMT
Last edited by Ionut Biru (wonder) - Tuesday, 06 April 2010, 09:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After the latest updates to gstreamer I am unable to play ".mod" (or ".xm", ".it", etc...) music files.
I can't do this neither in totem nor on rhytmbox.
VLC plays these files fine.
You can find example mod files in here:
http://modarchive.org/


Additional info:
* package version(s)
Using the latest packages as of 16/03/2010:
0.10.28-1
-bad 0.10.18-2
-good 0.10.21-1
-ugly 0.10.14-2

* config and/or log files etc.
issuing the command:
totem /path/to/file.mod
results in:
totem: malloc.c:4628: _int_malloc: Assertion `(unsigned long)(size) >= (unsigned long)(nb)' failed.

Steps to reproduce:

totem /path/to/file.mod

Watch the crash.
This task depends upon

Closed by  Ionut Biru (wonder)
Tuesday, 06 April 2010, 09:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  libmodplug-0.8.8-1
Comment by Francisco Pina (Stunts) - Monday, 29 March 2010, 09:25 GMT
Here's some more info:
Trying to play a mod file using gstreamer directly turns up the error in attachment.
The used command was:
$ gst-launch-0.10 -v playbin uri=file:///home/francisco/Music/Mods/KNGDMSKY.XM
Comment by Francisco Pina (Stunts) - Tuesday, 30 March 2010, 13:40 GMT
The bug appears to be in gstreamer-plugins-bad.

Asked for some testing in the ubuntu forums to see if the bug is upstream. The posts are interesting as there seem to be varying results. Could be architecture dependent. Can you test on i686?

Forum thread here:
http://ubuntuforums.org/showthread.php?t=1441750

Thanks
Comment by Jan de Groot (JGC) - Tuesday, 30 March 2010, 13:57 GMT
valgrind shows errors in libmodplug. Upstream changed to external libmodplug instead of their own copy, so that could explain the crashes that weren't present in the previous version.
Comment by Francisco Pina (Stunts) - Tuesday, 30 March 2010, 14:04 GMT
The forum thread indicates it's clearly a 64bit exclusive issue.
I'll report the bug upstream and link it here.
Comment by Francisco Pina (Stunts) - Tuesday, 30 March 2010, 14:09 GMT Comment by Francisco Pina (Stunts) - Tuesday, 30 March 2010, 21:05 GMT
Confirmed that mods play on i686. Works as advertised on my eeePC running Arch.
Should this be closed or should we wait for an upstream reply?

Loading...