Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#18658 - AIF hangs while downloading packages

Attached to Project: Release Engineering
Opened by xybre (xybre) - Friday, 12 March 2010, 18:54 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Sunday, 18 April 2010, 16:39 GMT
Task Type Bug Report
Category AIF
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version 2009.08
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm not sure of the cause, but perhaps the mirror server hiccups thereby causing a download failure even after several packages have been successfully downloaded. However AIF does not recover from this error at all, it just hangs.

`du -s /mnt/var/cache/pacman/pkg` confirms that no further downloads are taking place. AIF can be exited with ctrl+c and restarted, however you will have to begin download packages from nothing every time this occurs. Changing mirrors did not alleviate the problem. MY local network has had a stable, uninterrupted connection the the internet the entire time I was attempting to install Arch.

I experienced this using the net install ISO in VirtualBox.

The solution to bug #16277 would likely solve the symptoms of this bug as well:
1. notifying the user of current download speeds and when downloads halt
2. allowing a user to choose a new mirror and restart a failed download

If there is another underlying problem in the download script that causes it to halt then this should be fixed as well.
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Sunday, 18 April 2010, 16:39 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#16277 

Loading...