Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18640 - [xawtv] lacks scantv, doesn't compile with libquicktime installed

Attached to Project: Arch Linux
Opened by Giuseppe Borzi (gborzi) - Thursday, 11 March 2010, 18:11 GMT
Last edited by Jan de Groot (JGC) - Monday, 04 July 2011, 14:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: xawtv lacks three binaries: scantv, mtt and alevtd. scantv should not be missed because it's used to generate the channel file. Also, while packaging xawtv on my PC I got this error message

CC libng/plugins/read-qt.o
libng/plugins/read-qt.c:7:33: error: quicktime/quicktime.h: No such file or directory
libng/plugins/read-qt.c:8:35: error: quicktime/colormodels.h: No such file or directory
libng/plugins/read-qt.c:9:27: error: quicktime/lqt.h: No such file or directory
libng/plugins/read-qt.c:18: error: ‘BC_RGB888’ undeclared here (not in a function)
.....
libng/plugins/read-qt.c:263: error: ‘struct qt_handle’ has no member named ‘rows’
make: *** [libng/plugins/read-qt.o] Error 1
==> ERROR: Build Failed.
Aborting...

I kind of solved this problem by making a symlink to /usr/include/lqt named /usr/include/quicktime. I suppose, from the lack of {read,write}-qt.so in the package, that packaging works when libquicktime is not installed.

Additional info:
* package version(s) xawtv 3.95
* config and/or log files etc.


Steps to reproduce:
$ pacman -Ql xawtv| grep scantv
is empty.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 04 July 2011, 14:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 3.101-1.
Comment by Thomas Dziedzic (tomd123) - Friday, 12 March 2010, 21:48 GMT
I just did a rebuild and I can not confirm any of your problems.

I didn't get any of your errors.

cd pkg
find -name scantv
./usr/bin/scantv
find -name mtt
./usr/bin/mtt
find -name alevtd
./usr/bin/alevtd

namcap xawtv-3.95-7-x86_64.pkg.tar.gz
xawtv E: Dependency detected and not included (libgl-git) from files ['usr/bin/pia', 'usr/bin/motv', 'usr/bin/xawtv']
xawtv W: Dependency included but already satisfied ('alsa-lib')
xawtv W: Dependency included but already satisfied ('libxxf86vm')
xawtv W: Dependency included and not needed ('libgl')
xawtv W: Dependency included but already satisfied ('gpm')
Comment by Giuseppe Borzi (gborzi) - Friday, 12 March 2010, 22:05 GMT
The problem is that scantv, mtt and alevtd are not in the precompiled package downloaded from the server. Try to download it with
$ pacman -Sw xawtv
then check what it contains
$ tar -tzf /var/cache/pacman/pkg/xawtv-3.95-7-i686.pkg.tar.gz | egrep 'scantv|mtt|alevtd'
returns
usr/share/man/es/man1/scantv.1.gz
usr/share/man/man1/mtt.1.gz
usr/share/man/man1/alevtd.1.gz
usr/share/man/man1/scantv.1.gz
usr/lib/X11/app-defaults/mtt
that is to say, no binaries for the missing scantv, mtt and alevtd. For me, the compilation works fine as long as libquicktime is not installed, otherwise it fails. Have you compiled with libquicktime installed?
Comment by Thomas Dziedzic (tomd123) - Saturday, 13 March 2010, 02:03 GMT
I didn't compile with libquicktime.
Comment by Dale Blount (dale) - Tuesday, 16 March 2010, 04:11 GMT
Recompile here without changing PKGBUILD adds the missing binaries at least for me.
Comment by Thomas Dziedzic (tomd123) - Tuesday, 16 March 2010, 21:52 GMT
I compiled with libquicktime installed and got the same error.
The problem is that xawtv expects the header to be in /usr/include/quicktime/quicktime.h
libquicktime actually installs the header to /usr/include/lqt/quicktime.h
Comment by Giuseppe Borzi (gborzi) - Tuesday, 16 March 2010, 22:07 GMT
A way to avoid the quicktime error without uninstalling libquicktime is to use the --disable-quicktime configure option. But I still can't figure out why the missing binaries aren't in the package. Recompiling without modifications on the PKGBUILD makes a package containing the missing binaries on my system, the same as reported by tom and dale.
Comment by Thomas Dziedzic (tomd123) - Tuesday, 16 March 2010, 22:08 GMT
Another note: community/cinelerra-cv (20100313-1) : /usr/include/quicktime/quicktime.h
Comment by Thomas Dziedzic (tomd123) - Tuesday, 07 June 2011, 12:19 GMT
looks like upstream has been active developing in the repo: http://www.kraxel.org/blog/linux/xawtv/
more specifically.. http://git.linuxtv.org/xawtv3.git
Maybe we should try updating xawtv to try to get this old bug closed

Loading...